Need help? Check out our Support site, then


Switching between private and public at will

  1. When I set out to make my blog I made it private. Now I don't see an option to make it public. There's no way to uncheck the option "I would like my site to be private, visible only to users I choose" or to choose a different option that would make it public.

    I searched for an answer on Google and found a similar question, but the support person did not say how to fix the problem; they merely made the asker's blog public for them. I do NOT want my blog made public. I just want to be able to make it public temporarily, log out of WordPress and view my blog as it would look to any reader. Then I would log back in and make it private again, as I'm not done working on it.

    Is this not possible?

  2. You did not specify a blog address or reason for posting when you created this topic.

    This support forum is for blogs hosted at WordPress.com. If your question is about a self-hosted WordPress blog then you'll find help at the WordPress.org forums.

    If you don't understand the difference between WordPress.com and WordPress.org, you may find this information helpful.

    If you forgot to include a link to your blog, you can reply and include it below. It'll help people to answer your question.

    This is an automated message.

  3. That is SO not possible. The moment you make your blog public, the search engines will grab it and all of your entries will be made public even if you immediately make it Private again. Do not even attempt this if you are serious about privacy.

  4. Mmkay? I'll take your word on that for the time being... but what about when I AM ready to make my blog public? Since the option to make it public doesn't seem to be available through the dashboard, am I just going to have to ask someone from WordPress to make it public for me when the time comes?

  5. Bump. I would still like an answer on how to make my blog public when I'm ready (not yet).

  6. Dashboard >> Settings >> Reading

    You need to be logged in as an Admin to see that option

  7. Thanks, for replying. I'm logged in on the account that I created the blog with, so I can only assume that I AM logged in as admin. I still don't see an option in Settings > Reading to make my blog public. Only option I see is to invite certain users to access my blog.

  8. Anybody?

  9. Here's how to determine if you are logged in under the exact same username account that created that blog and who is the Admin of that blog. Clicking this link should display all your blogs registered under the same username, including the hidden ones: https://dashboard.wordpress.com/wp-admin/index.php?page=my-blogs&show=hidden

    If you do not see the blog here http://en.support.wordpress.com/my-blogs/ then
    follow this guide > http://en.support.wordpress.com/my-blogs/#my-blogs-dashboard-visibility

    If you have lost your log-in information you can visit https://en.wordpress.com/wp-login.php?action=lostpassword

    Note: http://en.support.wordpress.com/settings/privacy-settings/

    P.S. Do heed raiancoaster's warning above.

  10. Thanks for your reply. However I still don't have the answer I'm looking for. I am sure that I am logged in under the admin account, I did check the link you posted. The support page you linked to only tells me how to make my page private except to specific users that I invite, it doesn't tell me how to make my entire site public.

    I have tried, but I am UNABLE to deselect the "I would like my site to be private, visible only to users I choose" option. Is this a bug?

  11. The support page you linked to only tells me how to make my page private except to specific users that I invite, it doesn't tell me how to make my entire site public.

    Yes it does. Select option 1.
    Allow search engines to index this site. – This is the setting used by most blogs. It allows everyone to read your blog and enables your blog to be included in search engine results and other content sites.
    Note: http://en.support.wordpress.com/settings/privacy-settings/

  12. I have tried, but I am UNABLE to deselect the "I would like my site to be private, visible only to users I choose" option. Is this a bug?

    How weird! It must be so I tagged this thread for Staff intervention.

  13. It's a radial button, not a checkbox. To deselect it, you'll need to choose one of the two options above it instead, either "Allow search engines to index this site" or "Discourage search engines from indexing this site".

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.