Need help? Check out our Support site, then


Text editing problem: WP inserts problematic special characters.

  1. I'm experiencing a problem very similar to the one described here:
    http://wordpress.com/forums/topic.php?id=1204&replies=21

    I've read the FAQ and searched the forum. I'm running 2.0.4

    I've turned off the rich text editor, disabled my plugins (Evermore and Less), yet it seems something keeps on being inserted into specific blocks of text, with the effect of causing undesired breaks and preventing natural ones.

    This recurs even if I switch the text out into a vanilla plain text editor and paste them back into a new post. It doesn't seem to depend on special characters that I type, but invisible "Â"s are appearing that screw up the formatting. It's driving me insane.

    None of my text has been near MS word or the like. It was all typed in the TinyMCE editor. Now I'm using the faster non-MCE WP editor, the text seems to be unfixable.

    It was worse before I turned off TinyMCE, but even with the basic editor the problem is still there. Why are these paragraphs mangled? AFAI recall they were only typed in the WP editor.

    Example text:
    "I have time, so take the long way on the Circle Line to see Chiho Aoshima's work again. the towers in it are lit up, and appear 
    made to contain many people. Further round the line, dirty arches have had their graffiti thoroughly scrubbed off. Small chunks of culture that have been edited out, their closest reach to preservation the temporary signs of their passing. I wonder if it was any good."

    Those breaks are showing by cutting and pasting into this box, and if I cut and paste from a plan text editor, or retype from scratch, the breaks recur in the same locations.

    In the source, WP is doing crazy things to my paragraphs. The character "Â" shows up at the end of many words. Example:

    I have time, so take the long way on the Circle Line to see Chiho Aoshima’s work again. The towers in it are lit up, and appear made to contain many people. Further round the line, dirty arches have had their graffiti thoroughly scrubbed off. Small chunks of culture that have been edited out, their closest reach to preservation the temporary signs of their passing. I wonder if it was any good.

    The lines with the "Â"'s are making the problems, they cause premature line breaks then project way beyond the div, as you can see.

    I found a frustrating, slightly laborious fix in the text editor Scite: Turning on View > Whitespace shows two different forms of space being used. Normal, properly parsed space characters show with a mid level dot in that view, whereas the ones generating problems still show as spaces normally do. Using find and replace on the latter kind of space can wash the text clean and get it working properly.

    Is there any more information on this problem and why it occurs?

  2. Greets:

    I'm afraid you're in the wrong spot. You need to be over at http://Wordpress.org if you're running 2.0.4. You're running different software than we are and our answers don't apply to your setup.

    Good luck,
    -drmike

  3. Oh, sorry about that. Totally new to WP. Thanks for the pointer.

  4. No problem. :)

Topic Closed

This topic has been closed to new replies.

About this Topic