Need help? Check out our Support site, then


Text wraps around images but has awkward spacing

  1. I've been incorporating images into my blog posts more lately, but when I wrap the text around pictures (using the normal pop up window where I can select "left," "center," or "right"), the spacing gets funky. I'm talking random huge spaces between two words in the same sentence and things of that nature. How do I fix this? And is there any way to make the pictures have a nice, thin border or anything like that?

    Please help!

    The blog I need help with is jamblinman.wordpress.com.

  2. Hi there,
    I can help with that. The alignment icons in the WordPress editor are for aligning text; they are not for aligning images. http://en.support.wordpress.com/visual-editor/#alignment They are used to achieve wrapping text around images on either the right or left hand side, or to display an image that's centered without text on either side of it. If the text beside the images does not occupy the same amount of space that the image beside it does then the text wrapping will continue and the images and text that follow will have a staggered appearance.

    • Align-left means position left, with the rest of the content wrapping around the right side of the image.
    • Align-right means position right, with the rest of the content wrapping around the left side of the image.
    • Align-center means position center, with no wrap-around (= the rest of the content below the image).

    If for example you want two images to be side by side on the same line start by setting the alignment of both images to left. http://en.support.wordpress.com/images/image-alignment/

    To prevent the staggered effect what you do is insert the following snippet of code into the HTML editor after each image/text pair:
    <br style="clear:both;" />
    See > For more on WordPress formatting and spacing

  3. I'm talking random huge spaces between two words in the same sentence and things of that nature.

    If you have been copying and pasting text from elsewhere without using either icon 5 or icon 6 in Row 2 of the visual editor, please see here http://en.support.wordpress.com/visual-editor/#pasting-text

    Go to Settings > Writing and select “ ___ WordPress should correct invalidly nested XHTML automatically” and then scroll down and click “Save Changes.”

  4. The huge spaces show up because the text in the theme you're using is justified by default (aligned both left and right). You should either edit your posts, select all and set the text alignment to left, or switch to a different theme (preferably one with a wider main column).

  5. @timethief and @justpi: Thank you! I looked over all the options, tried it and now it looks much better. Much appreciated!

Topic Closed

This topic has been closed to new replies.

About this Topic