Need help? Check out our Support site, then


The Publish button missing

  1. The "Publish" and "Save draft"/"Update post" buttons no longer appear.The Publish module is empty. My drafts can't be published anymore.Can anybody help me fix it, please? Gratefully.

    The blog I need help with is roxanaiordache.wordpress.com.

  2. Have you done any troubleshooting? Whenever something like this happens immediately Force refresh and Clear Your Cache and Cookies > instructions here > http://en.support.wordpress.com/browser-issues/

  3. Exact same thing happened to me tonight. I just wrote the powers
    the powers that be. I will try to clear the cache, etc., but not
    sure if I can find my way back here.

  4. Well I just followed timethief's suggestions and it doesn't
    work. I would appreciate some help. On my computer, I can't
    switch to Firefox. Thanks. Just realized I will get an email
    if there's help.

  5. First off, are there modules to the right of the text area in the editor? If not, go to the upper right of the editor page, click screen options and select "2" column. Now scroll down below the text area in the editor page and find the "publish" module and drag it up and to the right of the text area and move it around until a grey outlined box appears and then release the mouse button. If you want categories and tags to the right of the text area as well (most do) drag those up and to the right also.

  6. roxanaiordache
    Member

    @timethief.Thank you, but I'd already tried all those before
    writing for your support.

    @thesacredpath. I tried, but it doesn't work.Thank you however and
    I hope U have more advice for me. It has to be a way to fix it!

  7. Did you look down below the text area to see if the publish module is down there?

    Also, are you an administrator on the blog?

  8. I just checked both of your Dashboards and was not able to reproduce the issue.

    Are you sure that clearing cache and cookies didn't help?

    http://en.support.wordpress.com/browser-issues/#clear-your-cache-and-cookies

    If so, please try in a different browser so we can rule-out a browser-specific issue.

    If that doesn't help, please contact us via http://en.support.wordpress.com/contact/

  9. roxanaiordache
    Member

    @thesacredpath. The publish module is on the right side, but the
    publish/preview button still missing. And yes, I am the
    administrator, I do all the work.

    @macmanx. Thanks 4 asking. Yes, I am sure. I did it and repeated
    it - the refresh, clearing, but using my computer buttons, not following your link, because
    I don't have a google account and quite franckly I'd rather not
    get one.

    You may be right about the browser, I'm using IE, I don't very
    much like FireFox (except for the fox icon:) ). Still, I'll try it
    for you to be able to undo my trouble.Thanks again, I really
    need my blogging facilities everytime, because I'm a publisher and
    I'm working online.

  10. Assuming you're referring to http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=32050 it's just a handy support document that includes cookie and cache clearing instructions for all browsers, no Google account required.

  11. @macmanx. But I've been asked for my account. Nevermind! I tried your advice and yes, it was about the browser. Thanks so much! Would you please tell me if I may recover my facilities using again IE, too?

    @thesacredpath. With FireFox, it worked, all the buttons are now visible on the righit side. But I'd still like to work with IE, because I find it much more handy than the other browsers. I mean, there I have all my shortcuts on the main bar (to BBC and other main sites) and only with IE I can reach my favorites.

    Thank you both, again. And @timethief too.

  12. You probably should be able to use IE, I'm not noticing any problems myself.

    Did you have any luck clearing your cache and cookies? Here's the instructions from the Google guide:

    Clearing your cache:

    1. In Internet Explorer, click Tools. If you don't see the menu, press Alt on your keyboard to show menus.
    2. Select Delete Browsing History.
    3. Select the checkbox next to "Temporary Internet Files."
    4. Click Delete.
    5. It can take several minutes for the cache history to be deleted. Once the files have been deleted, click Okay.

    Clearing cookies:

    1. In Internet Explorer, click Tools. If you don't see the menu, press Alt on your keyboard to show menus.
    2. Select Delete Browsing History.
    3. Select the checkbox next to Cookies.
    4. Click Delete.
    5. Once your cookies have been deleted, click Okay.

    They also link to this handy video:
    http://www.youtube.com/watch?v=LKTPncO-0_g

  13. @macmanx. Thanks, but it is the first thing
    I did and I do it from time to time. :)

    About IE, the publish button still doesn't show. It shows only when
    I use Firefox. Nevermind, I found a way to keep publishing.

    Thanks again and all my best!

  14. courtneycolewrites
    Member

    @thesacredpath,

    My Publish administrive box is blank. So, I did what you
    suggested above and tried to drag it. When I am dragging it,
    the Publish, Save Draft, etc buttons are visible, but when I
    release it into the gray box, it refuses to stay there.
    The blank Publish box returns to where it was.

    Any suggestions? I'm about to pull my hair out. I've tried
    every suggestion posted. :(

  15. roxanaiordache, well if Firefox works for you that's awesome! :) It's a better browser, IMO.

    If you still want to give IE a shot, the next thing I'd do would be to temporarily disable any add-ons, tool bars, and third-party security software (firewall, antivirus, etc) that you have running. If that works, reactivate each one individually until you find the cause.

    courtneycolewrites, any luck with clearing cache/cookies or using a different browser?

  16. Well, I still can't post from my computer. And I've done all of
    the things suggested above. I would like to know why it was
    working just fine and in one day, it died. I really liked MSN
    spaces and was learning to like wordpress. Too bad. Can anyone
    help me?

  17. Are you willing to use Firefox? It's free and it works.

  18. No, I can't download it on my very old computer. I read the
    above hints and just don't get it why it worked fine on my
    computer and in the last 2 days, it quit working.

  19. leslieannie, what browser and version are you running?

  20. IE 6; and I can't download anything else. So don't suggest it.

  21. Oh dear ... IE6 as it's a problematic browser that has driven web developers and designers crazy for years and Microsoft no longer supports it. :(

  22. Yeah, IE 6 is over ten years old with poor support for web standards. Even Microsoft is pretty much calling for its demise: http://ie6countdown.com/

    Is there any way to you could upgrade to at least IE 7?

  23. Nope. I just don't understand why this was working for at least
    a month and now it's not. I guess nevermind. Eventually, I'll
    get a new computer...

Topic Closed

This topic has been closed to new replies.

About this Topic