Need help? Check out our Support site, then


Theme bug report: INove interface bug with long posts

  1. I'm not sure if this should go here or the support forum, but I just found a bug in the INove theme.

    When viewing posts by category, 10 most recent posts are displayed on each page. But if those posts are really long, the main column got truncated after several posts, and the rest are pushed aside to the toolbar/widget area, which doesn't have enough width.

    DOM structure inspection reveals that the DIVs of the pushed aside posts got inserted outside of the #main DIV.
    This happens on both IE 8 and Firefox 3.6.

    The blog I need help with is adam5wu.wordpress.com.

  2. Well, I figured out the problem. It is not the INove theme, but the bug of html tag checking.

    I just migrated from Live Space. For some reason Live Writer had a notorious habit of formatting post using DIV tag instead of the Paragraph tag. So I spent some time correcting this in my posts, and somehow left an extra close DIV tag here and there. The html tag checker did not catch this error, and thus the layout of the page is altered.

  3. Did you go to settings > writing and select "WordPress should correct invalidly nested XHTML automatically" and then save?

  4. Thanks for the hint. Now I have it turned on.

    I saw the editor/server was doing some parsing and auto correction even without that option been checked. So I assumed the HTML code is been corrected automatically.

    Apparently there are different levels of corrections? :D

  5. There is some code that is not allowed, so the editor takes it out automatically.

    http://en.support.wordpress.com/code/

Topic Closed

This topic has been closed to new replies.

About this Topic