Need help? Check out our Support site, then


Theme looks different

  1. shiranirajapakse
    Member

    I changed the appearance of my page from chaotic Soul to Suburbia but it look nothing like the demo page. Suburbia has two large columns at the top and three rows of five columns below. But my page just has one long page. Why is this?

    The blog I need help with is shiranirajapakse.wordpress.com.

  2. Suburbia description notes http://theme.wordpress.com/themes/suburbia/
    live demo site http://suburbiademo.wordpress.com/
    Suburbia allows you to upload a custom logo for your site as a Custom Header Image in Appearance → Header.
    The custom header image is 155 by 155 (width, height).

    The number of posts you set to display here > Settings > Reading determines how many posts will display on the front page of the blog. It's by setting featured images at least 350 by 248 (width, height) as sticky posts that determines how many posts display side-by-side. Two posts each with featured images results in what you refer to as two columns.

    Suburbia description notes http://theme.wordpress.com/themes/suburbia/
    live demo site http://suburbiademo.wordpress.com/

    On the main page, Suburbia doesn't display regularly inserted images. They only display when a post is viewed on its own page - not on the front page. Only two posts with featured images in them display there side by side.

    To have front page image display you need to set a featured image to each post and make each post a sticky post. The size of the featured image does matter. The featured image works best with images at least 350 by 248 (width, height).

    Setting a Featured Image > http://en.support.wordpress.com/featured-images/#setting-a-featured-image
    Stcky posts > http://en.support.wordpress.com/posts/post-visibility/#sticky-posts

    If you don’t see the Featured Image module on your Add New or Edit Post page, please make sure you’ve selected Featured Image in your Screen Options. http://en.support.wordpress.com/screen-options

  3. shiranirajapakse
    Member

    Thanks. Some of it is resolved, it seems. I get the five columns in two rows but not the two columns at the top. I don't seem to be able to find how to make them two. Also the pages that already exist don't appear here, its only the posts. Do I have to manually change the pages to posts? meaning, do I have create new posts using the page info?

  4. Two posts each with featured images results in what you refer to as two columns. It's by setting featured images at least 350 by 248 (width, height) as sticky posts that determines how many posts display side-by-side.

  5. shiranirajapakse
    Member

    Why aren't the photographs shown on the posts page above each of the posts?

  6. shiranirajapakse
    Member

    Thanks timethief for the info about the two columns. I've got that going.

    I had no idea when I changed themes that it would be so hard. It means building the website/blog all over again.

  7. I have used this theme and I know it very well. If you do not set featured images of the exact size required and you do not mark the posts as sticky posts they images will not appear on the main page for posts in the blog, which by default is the front page.

    Why aren't the photographs shown on the posts page above each of the posts?

    Because the theme is not designed to display them on single post pages.

  8. That last sentence I typed is wrong.

    This is correct:
    On the main page, Suburbia doesn't display regularly inserted images. They only display when a post is viewed on its own page - not on the front page. Only two posts with featured images set in them of the correct size and marked as sticky posts display there side by side.

  9. I wish I could edit this thread but I can't. :(
    1. The featured images must be the required size.
    at least 350 by 248 (width, height)
    2. The featured images must be properly set up.
    http://en.support.wordpress.com/featured-images/#setting-a-featured-image
    3. The posts with featured images must be designated as sticky posts.
    http://en.support.wordpress.com/posts/post-visibility/#sticky-posts

  10. shiranirajapakse
    Member

    Ok I get what you are saying. But when I look at the Suburbia demo page there are two columns and then three of five. I've figured that out with much thanks to you. The Suburbia demo page also has images on top of the text in every column. I did designate the two pages with images as sticky posts but while the text appears the images don't appear on the front page but appear only when you continue and it opens in a new page.

    However, if you see the page http://ontheplumtree.wordpress.com/ the images have appeared with the texts. (I note this as its a page used by someone I knew but she didn't know how she got there)

    The posts i had in my previous theme have appeared as posts here too but minus the image. I did not make them sticky posts, they just became that by default. How do I get the image to appear on top of the column?

    Also would you know how I can retain more text on the columns when displaced on the front page before it moves to the next page on the continue prompt?

  11. shiranirajapakse
    Member

    Ok figured it out. The images have to be deleted and then copied back on again. How crazy is this?

    I still haven't figured out how to retain more text on the sticky posts before the "continue reading" takes you to another page.

    Thanks a lot. You've been a GREAT help. Much appreciated. Now I have to go tell my followers why they are getting to see the old pages all over again!

  12. I'm sorry it took me so long to get back to this thread.

    I still haven't figured out how to retain more text on the sticky posts before the "continue reading" takes you to another page.

    These days newer themes provide only excerpts on the main page for posts in blogs which by default is the front page of the blog.

    In Suburbia and any theme with an active excerpt box you can use this workaround
    You compose your whole post first and before you publish it you switch to the HTML (Text) editor, copy the code, paste it into the Excerpt box, and publish the post. http://en.support.wordpress.com/splitting-content/excerpts/#creating-excerpts

    If you do not see an excerpt box then go to screen options on the top right hand corner of your Admin page and include:
    Post – Likes and Shares, Format*, Categories, Tags, Excerpt, Send Trackbacks, Discussion, Comments**, Slug, Author, Revisions, Writing Helper

    P.S. On themes that do have an active excerpt function, the workaround works very well but you have to do it on every post you create.

  13. For the top two featured images, one images shows alone--large white space to the side--then the next is dropping down to next column--and is a large image next to small image for the next posts.

    I have gone thru all info above re: featured image, sticky and changed dimensions of original image to be at least
    350 W x 248 H, then to those exact dimensions within editing options within post. NOTHING.

    Any ideas?

    When I first set up this theme it worked fine...then one day....this problem started.

    Augh!

Topic Closed

This topic has been closed to new replies.

About this Topic