Need help? Check out our Support site, then


Thickbox photos appear on the top of the page

  1. Hey there, I have a problem with thickbox that I hadn't before and I don't know why. Every time people click on one of my photos to open it with thickbox, they have to scroll to the top of the page to be able to see it. As you can imagine this is really annoying; and sometimes it makes them believe that the photo didn't load because everything turns dark.
    Is there a way to make the photo appear over the part of the page in which they are? Or that the thick box window is on top of everything and irrelevant to the length of the page?
    Thanks.

    The blog I need help with is bearinginmind.wordpress.com.

  2. Are your referring to the workaround? The thickbox workaround we used to be able to use is an old one and I'm not surprised if it no longer works. See here > http://en.forums.wordpress.com/topic/how-to-get-the-image-url-from-media-upload-in-widget-field-1?replies=2
    There's no guarantee that Staff have not or will not change something that results in it not working anymore.

  3. Honestly, I have no idea what that is... I don't have a wide knowledge of this things, I just write "thickbox" in the "class" option, and it used to appear on top of everything but now I guess wordpress changed something, I don't know. Is there anything I can change on my blog so that it appears as I said before?

  4. Will you please post an active link to the blog in question?

  5. @timethief,

    http://bearinginmind.wordpress.com/

    That is strange! It's late at night for me but I wonder if it "works" in other themes? I'll have to investigate. But let's modlook this topic for now…

    The old "work around" has not worked for a couple of years, as far as I can remember.

  6. @Tess
    Thanks for entering this thread and helping. Is it possible that by ":thickbox" she means the Modularity Lite slideshow?

  7. No not a slideshow. I was fascinated with the thickbox back-when.

    It is certainly a "thickbox." Just click on one of her pictures: it is a thickbox. But as the original poster says, it pops up on the top of the page not over the picture itself.

    I could reproduce it in the text editor on a test blog. But I don't know

    I just write "thickbox" in the "class" option,

    Now my eyes are closing. Tomorrow is another day…
    http://www.youtube.com/watch?v=R-OoIvgtuzs

  8. The bigger problem is that while it sort of works, the thickbox effect is still visible only to logged in users.

    http://en.forums.wordpress.com/topic/thickbox-issues-new-windows-opening-instead?replies=19

  9. Thanks for your responses.
    Well I could edit the text editor if you tell me what to change, if that solves the problem.
    I hadn't realized but yeah, you're right, it only works for logged in users. Still, even if it's just for them, it looks much better with the thickbox, but if I can't solve the problem I guess I'll have to remove all the thickboxes.

  10. Oh and I read the topic you posted, I checked on the text editor and I don't have that target="_blank" in my pictures so there must be a different problem...

  11. No, the issue is not target="_blank." It has to do with the way cookies work.

    I tried "thickbox" in a couple of themes and they both exhibited the same problems: visible to only logged in viewers and in those cases the images open near the top of the screen not over the underlying image. I tried a couple of things to adjust where they would appear but everything I tried just moved the original images, not the thickbox.

    I'm out of ideas…

  12. Ok thanks, then I'll just get rid of the thickbox! Is there anything else that creates a similar effect for wordpress.com?

  13. Not that I know of.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags