Need help? Check out our Support site, then


Times are off for comments and upcoming events

  1. My times for comments are off by about 6 hours and my times on upcoming events are also off by about 6 hours. I set my time zone in settings and also set my time zone in my native calendar app (apple). It's driving me bananas! Any help is appreciated. Thanks in advance.

    The blog I need help with is eddiecarrizales.wordpress.com.

  2. Hi there,

    We are aware of a bug with the Upcoming Events widget that causes it to have a strange time lag with actual events - unfortunately my only advice is to set your Google Calendar AND your blog timezone settings both to UTC until they properly sync (up to two hours) and then set them back to the proper times. A word of warning - this hasn't worked for all users. We are working on an actual fix to this, but that's the work-around some users have found to be helpful in the interim.

    Can you link me to a few comments where the times are off?

    So sorry for all the time-related inconveniences!

  3. Time should be 10pm not 4am. The time is correct when I click comments tab on wordpress iphone app. But incorrect on actual site page. Not sure but it is the same time difference that my upcoming events widget is showing from my iCal feed.

  4. Can you confirm the proper times of the first two or three events for your upcoming events?

    I noticed that your calendar code is somewhat different from that I'm used to seeing. Could you describe where this code came from, and if you followed the steps found here:
    http://en.support.wordpress.com/widgets/upcoming-events/

    I'm still working on the comments issue. So far the only thing I can find is that the comments will register in the blog timezone, so if I set my blog to Chicago time, no matter where anyone else is, their comment will register in Chicago time. But I don't think that's exactly what's going on here, right?

    Thanks for the clarification!

  5. Calendar code is direct from apple calendar app. It's a shared calendar and I just copied the URL and pasted in the wordpress widget.

    Times should be metric lips rehearsal 7:30am and then 4:15pm for Friday feb 8. Feb 12 should read 4:05-5.30pm.

    The comment time issue is odd to me. It's a comment made from one of my students. She confirms that the time should read 10pm. Not 4am.

  6. Thanks for the additional clarification!

  7. We typically have users working with Google Calendars, so I did some digging for Apple Calendars.

    I noticed that when I imported my Cal code from Apple, I had the same problem! So I followed some instructions I found, and found out that although my local calendar is set to Eastern (where I live), my iCloud Cal was set for Pacific.

    Can you go to
    https://www.icloud.com/

    And log in

    Then, click on your name in the top right

    Adjust your timezone as needed

    (http://support.apple.com/kb/PH2614?viewlocale=en_US)

    You can also click on the system preferences there and turn on Time Zone Support, then refresh your calendar, and give it a few hours to sync:
    http://support.apple.com/kb/PH2677

    We are troubleshooting together, so please let me know the result after a few hours, once the calendar has had time to sync back up.

    Cheers!

  8. Ok I set the time zone on icloud.com.

    If all else fails may just move to google for my wordpress calendar...not too excited about that but if its all I can do its all I can do.

  9. Times are still off...I may need to go with google...sadly wordpress and apple don't play we'll together. Doesn't seem to make sense about the comment times being off too though...

  10. That is particularly strange to me, as well. I'm continuing to try to figure that out.

    If you don't like the Google Calendar interface, you may like this:
    http://www.busymac.com/

    It makes it a little nicer.

    I am very sorry for the inconvenience!

  11. Hi, I have similar problem. I am using an iCloud calendar and Upcoming Events in my Blog. The calendar is here:

    webcal://p01-calendarws.icloud.com/ca/subscribe/1/TiXl8ljXweqqnnjsjk4hzJ3hYnkSe_jsQGG_RXwRhuwhHsgIapy2sUMFja14Al9DpqsMazwVLNTYJ9wvX5xiCwYuhJt6U1PJ2Y4oQoDL4Ys

    That's the link I pasted into the widget. The events show up with some delay as expected, but they are 2 hours early. I am on CET on iCloud, my local calendar and in the blog. As a temporary fix, I let my events start 2 hours late, so they appear correctly on the blog, but that is annoying.

  12. Can you try testing the calendar in Google Calendar:
    http://en.support.wordpress.com/widgets/upcoming-events/

    I'd like to get some firm documentation around how iCloud calendars seem to work in the widget so that we have some information to go on, on our end.

    Right now, Google Calendar is the best supported calendar, however.

  13. I thought it would make more sense that you guys try out the iCloud calendar, as there is a community that may not necessarily want to move to the Google calendar. What would be interesting to know is, if the problem is with WordPress or with Apple. If you can show that the Apple calendar has problems, you have a good argument to encourage users to move to the Google calendar. If I understood some of the blogs entries correctly, some users seems to have issues with the Google calendar too.

    All right, so, why not try to produce a bit more happiness? :-)

    Cheers, Wolfgang

  14. Thanks for the tip Wolfgang - I will certainly relay it to the team :)

  15. Well, magic. Someone must have fixed the problem. Now, the times are correct. I just moved the artificially shifted times back to the correct time in my calendar, will see what the result will be when the update on my blog follows.

    Good news. Thanks.

  16. Just checked the new times in comparison with my iCloud calendar. Just fine. Problem solved!

  17. Yes - I'm glad you came back to check, because this has been addressed by the team. Success!

Topic Closed

This topic has been closed to new replies.

About this Topic