Need help? Check out our Support site, then


Too many e-mail notifications from WordPress.com News on one issue

  1. shadowoperator
    Member

    Hello. Please don't take this personally, normally I love getting news of new features from WordPress.com News, whether I can currently afford to implement them or not. But as of yesterday or the day before, I began getting a notification I'd signed up for about "More Widgets for your Blog" from someone who sent through upwards of 50 notifications yesterday, and has started again today heavily already, even though I've temporarily disabled the WordPress.com News blog from the Reader thingy on "Blogs I Follow." What can I do to get rid of this person's blog? I think there should be (or is there?) a special way to get rid of any particular news feature which becomes a nuisance if one's done reading about it (or is there one already)? Thanks. When all the folks are done chatting, I'll re-enlist!

    The blog I need help with is creativeshadows.wordpress.com.

  2. You can control the frequency of receipt of posts from blogs you follow.
    http://wordpress.com/#!/read/edit/
    Get new posts by email
    Never
    Instantly
    Daily
    Weekly

    You can also "unfollow" any blog byt clicking the "x" next to the permalinked blog name on that same page

  3. shadowoperator
    Member

    Thanks, I've already clicked the "x," but I think there may be a time lag between when the WordPress site records the request to discontinue and when the e-mail thing on my computer lets me know that i have new e-mail. The e-mail kept coming through in individual bits for several minutes after I disabled the WordPress.com News thing. I don't even want to get news for a while even weekly, because if it means I'm going to get a gezillion reports on the same entry once a week, it comes to the same thing: I still have to clear it all off my e-mail. Thanks again. You're doing a great job answering my neophyte questions, and I really appreciate it.

  4. As you can see there are two ways to stop the email updates from specific blogs. I didn't know there was a time lag. If this doesn't rectify in a few hours please post again.

  5. shadowoperator
    Member

    Hi, sorry that I have to get back in touch with this, but I wrote the above concern yesterday, after getting fast and furious e-mails from the person concerned and his "More Widgets for Your Blog" posting for a couple of days. I'm getting back in touch because it started again this morning, also fast and furious, at the rate of about 5-10 per minute. I'm beginning to feel that some kind of security has been breached or something, because I did go to the Reader page yesterday and unsubscribe, and then it happens again today. Can you help? Since I've already unsubscribed on my own site, should I just go ahead and go to his site anyway and unsubscribe again? (You sent the instructions above; I'm hoping that if I have to do so, that's it's a failsafe measure--this issue is receiving a lot of publicity, but I wonder if anyone else is being driven distracted by so much mail). Thanks.

  6. Did you click the link to be notified of Comments on this post?
    http://en.blog.wordpress.com/2012/07/17/more-widgets-for-your-blog/
    See > http://en.support.wordpress.com/comment-notification-email/
    It sounds like you did to me. Click the "unsubscribe" link at the bottom of the email you received.

  7. shadowoperator
    Member

    I don't think I originally clicked on the link to subscribe, but I did write back with a question (which as far as I can tell was only answered with all the e-mail--there was too much after a while to continue to search through it for an answer). But this may be what i need to do anyway. I deleted the original correspondence from my WordPress file, however, so I'll have to unsubscribe through another one. Thanks. I'll try it.

  8. shadowoperator
    Member

    Hi again. I had two options for unsubscribing to the blog. One was a plain "unsubscribe" and would've led to my being unable to receive any other posting from WordPress.com News. The second was a "modify subscriptions" button which allowed me to exclude a particular post. I chose the second, because I would like to receive other mail from WordPress.com News from time to time (and as you've told me, I can set the frequency of this on my Reader Page). Thanks for being so patient. I think this'll probably take care of the issue.

  9. Hooray! It sounds like you have been able to resolve this. :)

  10. shadowoperator
    Member

    Not without a lot of help! Thanks. :) The ironic thing is that I just a few days ago spouted off in my blog on the issue of the price of ignorance, though I was referring to literary issues. I guess we've all got our blind spots, eh? Mine happens to be machines, computers, devices, anything non-human that requires interaction. I guess I'm really lucky that there are so many kind, intelligent humans at WordPress forum to help me along.

Topic Closed

This topic has been closed to new replies.

About this Topic