Need help? Check out our Support site, then


trackbacks from my own blog?

  1. My blog is http://garbolaughs.wordpress.com

    I want to keep trackbacks/pingbacks on so that I am notified when another blog links to me; however, lately when I link to another one of my posts within my own blog (for example, if in a new post I say "check out my other entry about this here" and post a link to it) I'm getting trackback comments from that too, which to me doesn't make sense. I don't need to know that I've referenced myself within my own blog. Is there a way to turn this off or is it just how trackbacks work? I don't remember this happening on my old WordPress blog.

  2. That is the way it has always worked, and internal links such as trackbacks from one post to the other is something search engines like to see. Also, I've had a number of people not use the link in the post, but click on the link in the trackback to get to the other post. It is another way to get your visitors to relevant content on your blog.

    If you don't want the internal trackbacks simply delete them.

  3. Thanks for the info!

  4. You're welcome.

  5. panaghiotisadam
    Member

    You can go to Settings>Discussion and uncheck the option "Attempt to notify any blogs linked to from the article."

  6. @Panos
    But isn't it true that if she does that then it won't only be the internal trackbacks that are affected?

    We can stop self-pihs this way > http://en.support.wordpress.com/pingbacks/#can-i-stop-self-pings

  7. panaghiotisadam
    Member

    @tt: True and true!

    (Confession: I find the truncated URL trick rather inconvenient, so I keep the Discussion option unchecked, change it if I am to publish a post with links to other blogs then change it back...)

  8. You know, I was going to answer this question, but when I double-checked the self-ping doc referred to by timethief, I realized that I don't use that truncated URL method on my own blog.

    As far as I can tell, I have "allow trackbacks and pingbacks on this page" checked, and under settings, "Allow link notifications from other blogs (pingbacks and trackbacks.) "

    And I just make links to my own posts as usual, with the complete URLs. But I don't get those self pings.

    Am I misunderstanding something here? Could be, would not be the first timeā€¦

  9. panaghiotisadam
    Member

    If you've got those two options checked but get no self pings, then you probably have the "Attempt to notify" option unchecked. (Which is what I do too: I've got an awful lot of links to my own posts, and I have to update many of the posts all the time, so I'd get self pings all the time.)

Topic Closed

This topic has been closed to new replies.

About this Topic