Need help? Check out our Support site, then


Trouble Adding Images To Sidebar

  1. I've followed the instructions found on the FAQ about adding images to your sidebar. Problem is when I get down to the change button on the text widget, mine says done not change and it doesn't work. Is their another way???
    http://niecey456.wordpress.com/

    The blog I need help with is niecey456.wordpress.com.

  2. Please post the whole code you're trying to put into the text widget here between backticks. Backticks are those little apostrophe-like marks that are usually on the same key as the ~. So Backtick, all the code, Backtick. That makes it display properly so we can read it and look for errors.

  3. http://niecey456.files.wordpress.com/2009/02/anthonycaylee412.jpg
    I was following the FAQ on that where it tells you to use the URL of the image. I just don't have a change button to change it over, it says done. The instructions said to do it like this:
    <img src = "http://niecey456.files.wordpress.com/2009/02/anthonycaylee412.jpg" >
    I don't really know what you mean by back ticks.

  4. Post the code you're trying to put into the text widget here, with a backtick on either side. See the key that has the ~ on it? The backtick is usually on the same key, and it looks kind of like this '

    So it would be ' put your code here '

  5. <imgsrc="http://niecey456.files.wordpress.com/2009/02/anthonycaylee412.jpg">

  6. I back ticked. Did I do it right? I added what it said in the instructions on FAQ.

  7. <imgsrc="http://niecey456.files.wordpress.com/2009/02/anthonycaylee412.jpg">
    They showed up that time. Am I doing it right?

  8. There are a couple problems with the code you have. The following has been corrected:

    <img class="alignnone" title="Anthony Caylee" src="http://niecey456.files.wordpress.com/2009/02/anthonycaylee412.jpg" alt="" />

    If you want the image centered in the sidebar, replace "alignnone" with "aligncenter".

    If you are not familiar with HTML, my suggestion is to start a draft post, then insert the image and then switch to the HTML tab, copy everything there to the clipboard and then go to the text widget and paste it in.

    Also, I would suggest going to settings > writing and selecting "WordPress should correct invalidly nested XHTML automatically" and then click save changes at the bottom of the page. That will ensure that wordpress will correct any code problems for you in posts and pages automatically.

  9. Thanks, I'll try that. I've never had problems with images in posts, but I've done alot of them, that might be the problem.

  10. Problem Solved!!! Thank you both sooo much!!!!!

  11. The change to settings > writing will just make sure that an inadvertent error doesn't creep in on you.

    I'm glad it worked and you are welcome.

Topic Closed

This topic has been closed to new replies.

About this Topic