Need help? Check out our Support site, then


Trouble Loading Pages

  1. Hello,

    For the past two weeks I have been having difficulty loading pages on WP. I can open the home page just fine, but if I click on a Freshly Pressed page or something on my own page it either takes forever to open or fails to open. Another friend who uses WP told me that the company is having problems with a server. Does anyone know what is going on and if WP has any intention of fixing it?

    Thanks,
    Glendene

    The blog I need help with is glendenewolf.wordpress.com.

  2. I just clicked around on a lot of stuff on the main page of wordpress.com, and on freshly pressed listings and all loaded very quickly for me.

    Try logging out of wordpress, clear your browser cache and cookies, restart your browser and then try again.

    Also, if you leave your computer running all the time, try shutting it down and then restarting it. It may be that the temp files directories are heavily loaded or that perhaps the DNS cache needs flushing out (which should happen upon restart).

  3. thanks for the reply. I did what you suggested and unfortunately it did not work. I'm still having trouble loading pages. I am living in Azerbaijan. However, I've lived here almost a year and only recently started having this problem. Could it have anything to do with living in a different country? I'm not having trouble loading other webpages, just WordPress. Thanks again for your help.

  4. I can't get the freshly pressed page or anything else on the WP homepage to open today. My blog and dashboard works OK but nothing on the homepage. I tried your shutdown the browser advice and it still didn't work. I even shut down the computer and started it again but still nothing.

  5. There are so many things that can cause this. It could be that there is some of the internet down and that is putting much higher loads on other sections of the internet. Equipment failures, high traffic, etc., etc., etc.

    Again, I'm seeing no issues myself and the main wordpress.com site is quick and responsive just as it was yesterday.

  6. Hmmm...the interweb...so many possibilities unless of course there's limitations.

    Thanks for your help.

  7. Yeah, when you get to thinking about how complex it actually is, it is a miracle that it actually works as well as it does.

  8. I am having the same problem with the homepage. I can't get it to load, nor can I access Freshly Pressed in any way.

    I have been having problems with my Subscriptions page for 2-3 weeks and Support said they were working on tweaking some recent changes. But the homepage problem just started today. I am using Internet Explorer 8.

  9. When you experience such problems the first thing to do is to clear your browser cache and cookies. http://en.support.wordpress.com/browser-issues/
    The next thing to do is to make sure your browser is up to date. If it isn't then you will have problems. You can update here > http://browsehappy.com
    If your browser is up to date then be sure that your Flash is updated as well. You can use this link to see if your flash is up to date. http://www.adobe.com/software/flash/about/ If it isn't you can update it here > http://www.adobe.com/products/flashplayer/
    The way you connect to the internet (mobile, satellite, DSL, dial-up) and to your blog, and how many proxy server jumps etc. it takes to connect can cause problems. There maybe be problems with your ISP and/or with the proxy servers. There may be problems with your ISP so check for known issues.

  10. I've also been having trouble loading WP lately. I haven't noticed problems with any other pages so I really think it's WP's fault!

  11. @nodenisa
    Exactly which browser and version of it are you using please?

  12. I too am having this problem, and have done for the last few days. I'm now thinking that it's a wp problem.

  13. Hi Timethief,

    I am using Firefox 5.0.1, and I updated my flash drive. However, neither solution helped. It's weird, I can do some things but not others. For instance, since I wrote on this forum, I've been able to load a video blog, but today I am trying to load a written entry with some photos and cannot insert the photos into the entry. FRUSTRATING to say the least.

    Any other suggestions and thanks for your help.

    Glendene

Topic Closed

This topic has been closed to new replies.

About this Topic