Need help? Check out our Support site, then


Truncated blog entries not showing "Read More"

  1. Okay, what gives here? Only one of my truncated blog entries/posts is showing the "Read More" ... The other three don't have that. True, a client/reader could click on the thumbnail and it would take them to the full blog entry but I really think there needs to be a "Read More" at the end of each truncated blog entry.

    Besides which, it's supposed to be there - inserted automatically after you insert the split. So why is it only showing up on one blog entry (The Trade as One feature story.) Since ultimately I'm going to be posting dozens of blog entries in a very short period (2 weeks) I really will need the Read More to be there!

    Thanks so much for your help. :)

    The blog I need help with is jennikeast.wordpress.com.

  2. Did you actually put "read more" tags in the posts? Inuit types does that automatically. If you did, try taking them out and see if the automatic read more shows up. You might have to force refresh your home page to see the change.

  3. panaghiotisadam
    Member

    Yes, that's how the theme works: if you don't insert a more tag yourself, the theme displays an excerpt with a "Read more" tab at the end; if you insert a more tag, it works (if the excerpt you isolate is shorter than the automatic one), but no "Read more" tab shows up. You can create your own, but this shouldn't be necessary. In my opinion you should report this to staff: the custom more tag, at least, should produce a visible tab - like it does in Structure.

  4. Okay, looks like I will have to report it to the Staff as I did not insert a "Read More" --like you said, it should do it automatically.

    I just contacted them. Will let you know what they say (and hopefully help other people in the process.)

    Really do like this template...nice and clean and simple. :)

  5. @Panos, thanks for the confirmation. Strange behavior indeed and I'm with you, it should be fixed.

  6. I use Inuit Types too and I agree with Panos "the custom more tag, at least, should produce a visible tab - like it does in Structure ".

  7. panaghiotisadam
    Member

    Thanks guys...

    Clarifying a couple of points for jennikeast's sake:
    1) Custom more tag means this:
    http://en.support.wordpress.com/splitting-content/more-tag/#custom-read-more-message
    2) "You can create your own" in my previous post means you can create your own using HTML.

  8. Still haven't heard from Word Press support. How long does it take them on average to respond. Most support place usually send you a confirmation email acknowledging you contacted them. Do they do that here?

  9. @jennikeast
    OOPS! Perhaps we ought to have been clear about how long things take and how many of us there are. There are millions of us wordpress.com bloggers. It takes time for your ticket to make it up the queque and to be acted upon. Do not hold your breath expecting that the Inuit Types template will be instantly edited. The Theme Staff may not even choose to agree with us at all and they likely have other priorties set. Normally Staff don't waste time emailing to say they received your ticket, at least they never have on mine.

  10. Okay, well that's good to know...thanks for the heads up. :)

  11. I'm still experimenting but it seems that when I add just another line or two of copy it inserts the "Read More." Guess "it" doesn't like the post to be too truncated! Having said that, that's a bother because I don't want to add another line of copy as the next sentence runs into the one I wanted to end with--making it difficult to read. Any ideas?

  12. panaghiotisadam
    Member

    I thought I explained why this is so; trying harder:

    When you don't insert a more tag, the theme displays the first 55 words of your post, and appends its own auto Read-more tab. When you insert a more tag before the 55th word, you get the excerpt you want but no read-more tab. When you insert it after the 55th word, it is simply ignored: what you get is the auto tab of the theme, not the one you added.

  13. Okay, I got it...thanks. Meanwhile, I heard from WP support. According to them there isn't even supposed to be a "Read More" option with this theme. Here is the support ticket and response copied here:

    I did: Created truncated versions of my blog posts in the template
    > Inuit.
    >
    > I saw: No "Read More" at end of each blog entry (except for one).
    >
    > I expected: There to be Read More automatically insert after I
    > truncated each entry. Posted this issue in Forums - they advised me
    > to contact you as they said it should automatically be appearing.

    Hi There

    This is the default for this theme. It is not meant to show the Read More links at all, but since some of your posts have longer sections before the More tag, it shows up for these posts.

  14. panaghiotisadam
    Member

    Thanks too. You can quote what I explained above and tell them their reply is wrong.

Topic Closed

This topic has been closed to new replies.

About this Topic