Need help? Check out our Support site, then


trying to remove comments from page [twenty twelve theme]

  1. hello!
    i am trying to disable comments on all of my pages. it doesn't seem to be holding on two of my pages {here} and {e-course}. i keep going back in under "screen options" but when i update the page, it keeps going back to showing the comments.

    any help appreciated!
    michelle

    The blog I need help with is michellegd.com.

  2. You can override the default settings and enable or disable future comments on any individual post or page.
    http://en.support.wordpress.com/enable-disable-comments/

    Any existing posts or pages will need to have comments disabled manually via editing. You can use the bulk edit feature in the all posts and all pages screen to make that quicker.
    http://en.support.wordpress.com/posts/edit-posts-screen/
    http://en.support.wordpress.com/pages/edit-pages-screen/

    Note: By default, new blogs on WordPress.com will have the Discussion hidden. You can reveal it by clicking on Screen Options http://en.support.wordpress.com/screen-options/ on the top right corner of your Admin page, and checking the box that says Discussion so the module is included. http://en.support.wordpress.com/modules/#list-of-modules

    Unrelated issue:
    Inappropriate use programming language such as { } in page titles is not recommended. Read why here > http://onecoolsitebloggingtips.com/2013/07/21/avoid-special-character-use-in-titles-and-tags/

  3. thank you for providing all these links!

    the comments option is showing up on just two of my pages. "here" and "e-course". i have NOT selected comments under screen options (i.e. discussion should be hidden) so i can't figure out why the comments show up on those pages.

    please advise further and thank you,
    michelle

  4. Any existing posts or pages will need to have comments disabled manually via editing. You can use the bulk edit feature in the all posts and all pages screen to make that quicker.
    http://en.support.wordpress.com/posts/edit-posts-screen/
    http://en.support.wordpress.com/pages/edit-pages-screen/

  5. a) What you select in Screen Options determines what shows on that particular dashboard screen, not what shows on your actual blog pages.
    b) See this post of mine, under "Faster way" and "Even faster":
    http://wpbtips.wordpress.com/2010/04/23/comments-off-1/

  6. thank you to both timethief and justpi,
    but...

    i have gone back in to individual pages (as well as trying things via bulk edit). i have selected comments to show on pages and then de-selected them. i have done this numerous times.
    no matter what i do: i have screen options configured so that comments should NOT appear on any of my pages (which is what i want). YET comments continue to show on the "here" and "e-course" pages (which i do not want).

    i can't seem to clear them.
    i understand all the links you've both sent. and these links are telling me to do exactly what i've already tried and re-tried.

    i don't know what to do!!!

  7. okay, update!
    i think i got it! i think i ended up fiddling with the page template.

    thank you both, time thief and justpi!!!
    much appreciated :)

    michelle

  8. You're welcome from me. :)

Topic Closed

This topic has been closed to new replies.

About this Topic