Need help? Check out our Support site, then


Twenty Eleven Sidebar on bottom

  1. I am working on a blog for a ministry I am involved in and it has had some tricky issues. I had everything nice and the way we wanted it and just recently it pushed the sidebar down to the bottom of the page. I went in and cleared out the custom editor so it is strictly the Twenty Eleven theme now, but the sidebar still shows up all the way at the bottom. We have our recent posts and a small text blurb in the sidebar. Even if I switch these items from main sidebar to showcase sidebar they still show up on the bottom. Can anyone help?

    The website is adventurescalling.wordpress.com if that helps. Thanks in advance.

    The blog I need help with is adventurescalling.wordpress.com.

  2. I haven't had a chance to look at that link, opening it right now. I kind of fixed it. I went into edit posts, and made all posts drafts. This brought it back up, and then one by one(lucky there are only 8 posts right now) I published them. It appears that there are two posts that when published push the sidebar to the bottom.

    Any clue on what the issue would be?

    I'm also wondering if it is not specifically those posts but once we have a particular number of posts on the page.

  3. I can see your two widgets are there in the sidebar where they should be. This is more likely to be a brows issue.
    http://en.support.wordpress.com/browser-issues/

  4. Wow, I was actually kind of close with that change to draft, then republish business. Guess it was some XHTML in the posts. Will ticking that box prevent it all the time or do I need to pass along some sort of guideline to the person that posts content on our page. I'm just the guy that edit(s) the style of the page.

    Thanks for that link though, incredibly helpful!

  5. @ghatch, if you look at the link that justipi gave you, you will see that you had some bad HTML in one of the posts - that is a common occurrence around here. The link explains how to fix it. If you copy directly from Word instead of using the paste functions in the editor, that can cause it.

  6. Thanks, Hnsaifi, I was viewing it in Safari, Google Chrome, and Firefox(using Firebug) and it was appearing wrong in all so I am/was quite sure it wasn't a browser issue.

  7. @ghatch

    Any clue on what the issue would be?

    justpi identified the cause and provided the solution when he posted this link > http://en.forums.wordpress.com/topic/problems-with-bueno?replies=4#post-805167

    In most case the reason a sidebar has fallen and is displaying below posts is either due to copying and pasting or it can also be a result of importing text containing invalid HTML or an open HTML tag. When bloggers copy and paste text from elsewhere without enabling the setting justpi indicated and do not use either icon 5 or icon 6 in Row 2 of the visual editor this can result. Thet's why Staff have provided this entry > http://en.support.wordpress.com/visual-editor/#pasting-text

  8. Thanks time thief! I've seen you show up in a lot of threads people have started and am thankful for all of your help. I have no idea if any of the content was copy/pasted since I don't write the content or posts, however the fix with ticking the fix XHTML box has done the trick and fixed the issue.

    I'll pass word along to our content manager to be weary of copy/paste though, hopefully that will make sure we avoid these issues in the future.

    Thanks again everyone for your help, you are all a great community!

  9. @ghatch
    Thanks for the thanks but it was justpi who provided the solution in this thread. Now that Writing Setting is enabled it's not likely you will have any copy and paste issues as the software will automatically make corrections for you. Best wishes with your site.

  10. I'm also wondering if it is not specifically those posts but once we have a particular number of posts on the page.

    It's due to infinite scroll. You can disable it when you've at least one widget in footer widget area.
    Setting > Reading > select number of posts to show.

  11. @hnsaifi:
    No, it wasn't a browser issue, and it's got nothing to do with infinite scrolling either.

    @ghatch:
    You're welcome.
    If you want me to me more precise, this issue is always caused by a stray closing div tag.
    Yes, if you keep that option enabled you won't see such a problem again - except if there's a stray div tag in a text widget: the option auto-corrects bad HTML in posts and static pages only.

  12. Sorry if I'm wrong in getting what was he saying. But he was asking, " but once we have particular number of posts on the page."

  13. Yes, but they also said they turned all the posts to drafts then started turning them to published one by one. The problem wasn't the number of posts by itself, the problem was bad HTML in one post: so the main page would only get messed up if that post was present, no matter how many others were present as well.

Topic Closed

This topic has been closed to new replies.

About this Topic