Need help? Check out our Support site, then


Twitter Timeline Widget disaster

  1. I have attempted to put my Twitter Timeline 'shortcut' widget (I am @galpix - yes I now not to use the "at" in the widget) onto my new blog and have done this, using your instructions, at least one dozen times, probably more. It does not seem to work for me. Help! I am about to give up and try Blogger!

    The blog I need help with is georgiaphotographers.wordpress.com.

  2. What did you put in for the number? The instructions say:

    [twitter-timeline id=1234 username=yourhandle]

    In the shortcode, id is the long number you see in the URL while editing your Twitter widget, and username is your twitter handle, without the @ symbol.

  3. Yup, over & over again. I edit the extremely long code Twitter gives me until it looks exactly like that. When I look at it in Appearances my code is never there, and I do it all over again. I am frustrated beyond belief. If I can't get this to work today, I am taking my blog elsewhere.

  4. What is the code that you received from Twitter when you created your widget there? Paste it here between backticks.

  5. Also, paste the shortcode you created between backticks.

  6. Perhaps that's the problem; I'll give it another try using the backtick ( ` ) characters, thanks.

  7. I think I better take a walk first, then attempt the widget again!

  8. You do have to create your Twitter timeline widget on Twitter first before you can embed the shortcode on your WordPress.com site.

    Please also make certain that is the Twitter timeline widget you are referring to and not the simpler Twitter widget. http://en.support.wordpress.com/widgets/twitter-widget/

  9. I give up.

  10. I've done everything as advised and as is in Help; obviously I am seriously developmentally disabled and never knew before.

  11. What I meant in my above answer is to post the code here in the forums between backticks- not on your site. Sorry if that was not clear.

    Create the widget on Twitter (under your "Settings>Widgets") by clicking on "Create New". You can choose your timeline, your favorites, a list or a search term. Fill out the information requested in the form and then click "Create Widget".

    For an example, here's one I created with the code Twitter gives you:

    <a class="twitter-timeline" href="https://twitter.com/penelope" data-widget-id="33546993168249XXXX">Tweets by @penelope</a>
    <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>

    Out of all that mess, the only things you want are are the username and the widget id (each widget has its own unique ID#), which goes into the WordPress.com shortcode like this:
    [twitter-timeline id=33546993168249XXXX username=penelope]

    Of course you use your own unique widget ID# and username once you've created the widget on Twitter. Once you have them, type the twitter-timeline shortcode in a text widget in your site's sidebar.

  12. Many thanks, I thought that's what I deleted and that's what I left but will try it again.

    Have been doing a bit of online research to get away from it awhile.

  13. Here is a problem, using the link you gave for Text Widgets, "Once you add the widget to your sidebar from Appearance -> Widgets screen, you’ll see that the widget settings look like this:"

    I am NOT seeing a screen that looks like that! The Twitter Timeline Widget is placed in my Sidebar list; all I can see to do is Edit it once again, in the very way instructed; title & Red My Tweets show on the site, but not active link and no Tweets there.

    Where is this other screen? I feel so stupid!

  14. Oh dear. I thought you were trying to use the shortcode as raincoaster mentioned above. That does go into a text widget.

    The twitter timeline widget is configured a little differently and actually more easily. You still need to use the unique widget ID number that twitter gives you when creating your widget on twitter. After you've dragged the timeline widget into your sidebar, just copy and paste that ID number into the Widget ID line. Save it. Done. (Hopefully.)

  15. OK-I dug a little further into the code on your homepage and it looks as though you are missing the ID# that is needed in the Timeline Widget.

    Let's start from scratch?

    1. Take the current Twitter Timeline Widget out of your sidebar to the top area "Available Widgets." This will delete anything you've put in the widget previously.
    2. Go to Twitter and create a timeline widget (Twitter>Settings>Widgets>Create New) and save it. Note the ID# that Twitter gives you.
    3. Open your WordPress.com Widget Dashboard and drag the Twitter Timeline Widget to your sidebar. If it doesn't automatically spring open, click the little down arrow on the right of the title bar.
    4. Copy and Paste the Twitter widget ID# previously noted into the Widget ID line.
    5. Save your widget and close.

    Just to be on the safe side and make sure this wasn't a theme-related issue, I switched my test site to Origin (which is the theme you are currently using) and the Twitter Timeline Widget I created appears there.

    If that doesn't work for you, then I am at a loss for what to suggest further.

  16. I added twitter timeline to the sidebar. On my blog it doesn't show anything at all, just "My tweets" in link format (which is misaligned and the link doesn't EVEN WORK).

    On the sidebar, the ONLY (and i say ONLY i mean only) parameter they want is widget ID. And I put it in correctly.

    Therefore, what in the flying fish is wrong?

  17. This seems to be the same error that the OP received.

    Can I assume that you first created your timeline widget on Twitter (see my point #2 in the post just above yours)?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.