Need help? Check out our Support site, then


Twitter Widget Issue

  1. Unable to show tweets, I have already added the widget and followed all the instructions from both ends, but it is only showing "My Tweets" instead of the actual tweets from Twitter. I am using the Twitter Timeline Widget, I was using the one prior to this widget and it was working fine. Is there a way to make my tweets post again?

    Also on my Connect With Me page, I can't seem to get the highlight from around the Twitter image off, is it something in the img HTML code I am leaving out?

    Thank you so much :) - Michelle

    The blog I need help with is thisgirlg33kischic.wordpress.com.

  2. Hi Michelle

    Try deleting the widget from your Twitter settings and creating a new one. Then paste the ID from the new widget on Twitter into the widget on your blog and see if that helps. http://en.support.wordpress.com/widgets/twitter-timeline-widget/

    The frame around the twitter icon is generated automatically when you add a caption to the image on some frames. You might be able to remove it using the Advanced Options if you edit the image in the page editor, but I don't know exactly what you'll need to change to make the frame disappear. http://en.support.wordpress.com/images/image-settings/

  3. I wished it worked Kokkieh but it didn't this new Timeline Widget doesn't want to work. I had tried that technique before I posted the question, and have been trying it multiple times unsuccessfully :(

  4. I'll tag this thread for staff to follow up. Hopefully they can help you to get it working. Please be patient while waiting for them to respond.

  5. Hi Michelle,

    Sorry for the trouble you're having with that widget! I just checked the Twitter Timeline widget on your blog, and I don't see a widget ID entered there. As kokkieh mentioned, you'll need to get that ID from Twitter — it's the number in the URL (the address in your browser's address bar) on the page where you set up the widget on Twitter: Twitter Timeline Widget

    If that's not working for you, could you let me know exactly what you're entering in the "Widget ID" section of your blog's Twitter Timeline widget? That will help me investigate this for you. :)

  6. Also on my Connect With Me page, I can't seem to get the highlight from around the Twitter image off, is it something in the img HTML code I am leaving out?

    That's the image border, which is added automatically by your theme to all the images you post on your blog. You can get rid of that border by editing the image settings:

    Image Settings

    In the "Advanced Options" for the image, next to "Image Border," you can enter 0 (zero) for the width to remove that border. Please let me know if you have any questions about that. :)

  7. Hello everyone, I have the same issue with the Twitter timeline widget and would love to know how to solve it. Following this thread with interest. The blog I need help with is http://www.andotherpoems.wordpress.com

  8. I should add that on my blog I've set the tweets to appear on Pages only.

  9. Hi josephinecorcoran, I see that your Twitter Timeline widget is also missing the Widget ID. As mentioned earlier, we have a guide for getting that ID here: Twitter Timeline Widget

    If that doesn't work for you, please let me know exactly what you're entering as the Widget ID in your Twitter Timeline widget so I can take a look.

  10. Hi Rachel and thank you so much. What I was doing wrong was copying and pasting the whole link and not just the id number. I really appreciate your fast response. Thank you and I hope this is resolved for Michelle as well. Wishing you great days! - Josephine

  11. Thanks for letting me know, Josephine! You're very welcome. :)

  12. When I entered the information in Twitter Timeline Widget area where it asks for Widget ID:

    I pasted in: [twitter-timeline id=490781451357409280 username=girlg33kischic] then I hit the send button and it blanked out the Widget ID:

    By the way girlg33kischic is my twitter handle. Thank you so much for everyone trying to help :)

  13. @rachelmcr I changed the widths to 0 and it did not take away the border around it :( plus in the image itself I tried changing it to a 0 and it didn't work, must I publish it instead of just viewing the page afterword to see the change? Thank you Rachel :)

    [caption id="attachment_61" align="aligncenter" width="69"]<img class="wp-image-61" src="http://thisgirlg33kischic.files.wordpress.com/2012/07/twitter-bird.gif" alt="My Tweets" width="69" height="77" /> My Tweets[/caption]

  14. Hi Rachel - what you need to enter in the box is ONLY the number starting 49078 that you've pasted above - not the whole thing. I have been doing the exact same thing for months so you are not alone in your mistake! Best of luck with it. - Josephine

  15. @thisgirlg33kischic - just to be clear the WHOLE number but not the words and symbols before and after it. Hope this makes sense!

  16. @josephinecorcoran WHOOOOOOOOOOOOOOOOOOOO HOOOOOOOOOOOOOOOOOOOO !!!!! It worked, they really should change the how to and put add the number only, it is very confusing otherwise, thank you all for all your help.

  17. @thisgirl33kischic - So glad it's worked for you! Thanks for starting the topic, I've suffered alone in silence for months. :-)

  18. @josephinecorcoran now if we can get them to change this user guide to say paste the numerical code in ONLY that would be great :) http://en.support.wordpress.com/widgets/twitter-timeline-widget/

  19. @thisgirl33kischic - I agree that would be much clearer. Why don't you post that in the ideas forum? or @rachmcr - thanks for your help, are you able to act on Michelle's suggestion?

  20. @thisgirl33kischic - although (regarding my previous comment) the screenshot there clearly only shows the numeric code in the box. Anyway, it's a fantastic widget!

  21. It is a definite improvement over the previous Twitter widget :)

  22. I changed over a few days ago. Since then I can't see my tweets on my Mac Pro using either Firefox, Safari or Chrome... all latest versions. All I see is the text "My Tweets"

    I have asked some of my readers if they can see it working properly, about 50% can and the other 50% can only see "My Tweets" or blank space.

    Blog: http://www.caravanchronicles.com

    Simon

  23. @simonpbarlow - before I posted this 3 of my friends checked and it only showed My Tweets. Once I put in the just the ID# only I saw the twitter widget pop in, and my friends saw it too.

  24. thisgirlg33kischic - I've put only the ID# number in... some people can see the tweets, others, like myself can't.

    I can see the tweets if I look at the blog on my wife's Macbook... but I can't see them on my Mac Pro.

    S

  25. @simonpbarlow - Just to tell you, I can see your tweets perfectly. Have you refreshed the page? Hope you sort it out - I'm sure you will.

  26. @thisgirlg33kischic @josephinecorcoran
    I think where you went wrong was to follow the instructions for embedding, where you have to use the entire shortcode. The instructions are on the same page as the widget instructions, and in fact comes first, so I understand how you could have got mixed up.

  27. @simonpbarlow
    It could be caused by a browser extension on your computer. It happened to me as well and it turned out Avast Antivirus's browser extension was blocking it. Deactivate any browser extensions/add-ons and see if the widget becomes visible. Then add your extensions back one by one to find out which one is causing the problem. That could be the problem in the case of your readers who don't see it as well.

    For the record, I can see it just fine.

  28. Hi josephinecorcoran
    Thanks, some people can see them some can't.

    I've done a browser refresh and cleared browsing data on all three browsers I use. Also removed AdBlock to check that wasn't causing any issues too.

    S

  29. Hi kokkieh
    Don't use Avast - on a mac. I have disabled all the browser add-in's and extensions without much success.

    At the end of the day its annoying but not a show stopper.

    S

  30. Hi everyone, thanks for the feedback! I'm going to look at reorganizing the information on that support page to clarify which instructions are for the widget and which instructions are for embedding your Twitter timeline on a post or page. :)

    Simon, do you have Javascript enabled in your browser? That's a common reason why your Twitter timeline won't show up on your computer when others are able to see it.

Topic Closed

This topic has been closed to new replies.

About this Topic