Need help? Check out our Support site, then


Unable to delete/edit custom Sharing services

  1. Hi. I noticed there was a change in the way Sharing services work.
    http://en.blog.wordpress.com/2011/08/11/making-your-posts-more-beautiful-than-ever/

    I do realize that instead of selecting if each button is either smart or regular, there is now an option called "Button Style" applicable to all buttons. There is one small problem with that though: I am now unable to delete or to edit the custom sharing services I created.

    As an example, I tried creating a button for Technorati after the change was effective. It was created alright, but I am now unable to delete it.

    Thank in advance to staff for looking into this.

    The blog I need help with is airodyssey.net.

  2. Just to clarify: if you go to my blog, you will not see a Technorati button indeed. I dragged it to the "Available Services" for now, but before, I could have simply deleted it while it was in "Enabled services". Now the option is simply gone.

  3. Yes, I noticed that as well. I can drag a custom button to "available services," but I can't delete it once it's there, and I can't even see the contents of the customized button to make any changes to it.

  4. This is somewhat indeed. Hope it will be fixed soon.

  5. Sorry for the first sentence in my previous post. I meant: This is confusing indeed.

  6. Looking into this.

  7. You should now be able to delete custom services that you've created. If you need to change the details of a custom service, you can just delete them and re-add them with the new options. Thanks for the report!

  8. "Delete and readd them"? That's kind of inconvenient because it would reset the stats for that particular service each time, especially if it's something as trivial as changing the icon or the spelling. Isn't there another way?

  9. I deleted my cache memory and emptied my cookies and I am still unable to delete custom services. There is no button or option that I can see. All I can do is drag and drop services between "Available" and "Enabled".

  10. This is really annoying for me too. I want to change the image for one sharing button, and to do that I would have to set it up completely new, which means looking into how that works in the first place, as I have no idea anymore. :( Why can't we edit those buttons like before?

  11. mannerofspeaking
    Member

    Yes. I have the same problem. Occasionally the URL for the image for a self-created share button changes or is taken down and you need to use a new one. Under the previous system, the buttons could be easily edited.

    If you look at the "More" buttons on my blog you will see that many of them are missing images. For now, I do not want to have to create a whole new set of buttons.

    I have also noticed as of this afternoon that the Facebook Like button has gone all wonky on WP.com blogs.

    John

  12. I have the same problem. I can not remove the buttons of service I created and would like to modify some images. Before, if you could modify and delete. Why does this happen?

  13. We are working on resolving this issue. I'll let you know once it's fixed. Sorry for the inconvenience!

  14. I noticed that there is now a little "X" next to sharing services. So that solves part of the problem.

    But I'm not marking this thread "resolved" yet for a simple reason...

    As I said earlier, it's inconvenient to have to delete the service and create it again simply to change the icon or the spelling of a service. Also, it resets the stats for the service each time. I hope you'll consider providing the possibility to simply edit a custom service like before.

  15. miapialingonfia
    Member

    I have a similar problem as well! I don't want anyone to share my posts out at twitter or Facebook etc.. But there is no chance for me to change it - I have tried several times to remove the "x" in the sharing-boxes, but the sharing-buttons seems to be here to stay.
    I will be very very very happy if you can help us all..hmm..now?

    thanx!
    Mia

  16. @miapialingonfia
    Have you tried to disable all sharing buttons and been unable to do so? Is that what you are expressing?

  17. mannerofspeaking
    Member

    @miapialingonfia

    You have three share buttons that appear when one clicks on an individual post in your blog: WP Press This; Twitter and Facebook. To remove them, do the following:

    1. Go to your Dashboard.
    2. Click Settings (bottom left)
    3. Click Sharing.
    4. Find Twitter and Facebook in "Enabled Services".
    5. Drag them, one at a time, to "Available Services".

    They will not longer appear on your blog. Although Facebook and Twitter cannot be deleted, they can definitely be deactivated, which gives you the result you are looking for.

    Hope this helps.

    John Z.

Topic Closed

This topic has been closed to new replies.

About this Topic