Need help? Check out our Support site, then


Unable to edit "Front Page Displays"

  1. In Reading Settings, I do not have the choice of Front Page Displays...

    Moreover, my posts are not in order (most recent first NOR oldest first - I'd like to show most recent first).

    Thanks for your help!

    The blog I need help with is thelongdistancefriends.wordpress.com.

  2. On post order I'm seeing 23 Oct, 23 Oct, 17 Oct. It appears in order to me. Go to settings > general and make sure your offset from GMT/UTC is set correctly for your time zone. If you changed it between posts, that can mess up the order. You can change the order by changing the published date as explained here: http://en.support.wordpress.com/posts/schedule-a-post/ .

    At the top of settings > reading, you will see a section labeled "Front page displays." If you are looking to set a different page as a static landing page for your blog, you do it in that section. You have to create and publish that new page before you can choose it from the "front page" pulldown: http://en.support.wordpress.com/pages/front-page/ .

Topic Closed

This topic has been closed to new replies.

About this Topic