Need help? Check out our Support site, then


unable to publish new post

  1. why am i getting the message 'invalid request' when i try to 'publish post' ???
    Blog url: http://alwaysfaithful.wordpress.com/

  2. (1) If you are trying to create a post on the WordPress.com home page here http://wordpress.com/#!/post/ then forget that please. Instead create posts only on your own dashboard here > Dashboard > Posts > All Posts > Add New
    http://alwaysfaithful.wordpress.com/wp-admin/post-new.php

    (2) Are you using the secure https:// login?
    http://en.support.wordpress.com/https/ If not then try using it.

    (3) Exactly which browser and version of it are you using. If you aren’t sure click here to find out > http://whatsmyuseragent.com/

    Note 1: If you are using an IE9 browser in compatibility mode that makes it render as IE7 and IE7 is not supported. To disable see > http://www.sevenforums.com/tutorials/1196-internet-explorer-compatibility-view-turn-off.html

    a. Try clearing your browser cache and cookies > http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=32050

    b. Try using the browser with all extensions or add-ons disabled

    c. If applicable try updating the browser to the latest stable version http://browsehappy.com/

    d. Make sure third party cookies are enabled on the browser http://support.google.com/accounts/bin/answer.py?hl=en&answer=61416

    e. Also confirm JavaScript is enabled http://www.google.com/adsense/support/bin/answer.py?answer=12654

    f. Then confirm Flash is updated http://www.adobe.com/software/flash/about/ and if required installing the latest version of Flash http://www.adobe.com/products/flashplayer/

    g. Try resetting your router and modem and rebooting your computer and then logging in using the secure https:// log-in

    h. Try using another browser. You can download one here http://browsehappy.com

Topic Closed

This topic has been closed to new replies.

About this Topic