Need help? Check out our Support site, then


Unable to view domain-mapped blogs

  1. Every time I try to view a page on a domain-mapped blog (you know, xyz.com instead of xyz.wordpress.com), my browser keeps reloading the page over and over, without actually displaying it. I'm using Firefox 2.0.0.6. If I turn off Javascript, the page will load and display normally, but since so many sites need JS, I can't keep it turned off all the time.

    I was wondering if I'm the only one who has this problem or if others experience it too.

  2. @kimiko
    You are not alone ... lol ... I leave this response to staff ... I'm hungry so I'm going to eat supper now ;)

  3. Oooh, this does not take me to my happy place.

  4. I didn't know how to break it to you gently, rain ... and I too have a domain hosted here ... didn't want to cause a stampede ... Beloved has said supper is served (he's sexy and he cooks!) ... I'm out of here.

  5. @kimik0

    I've not seen this happen, please drop a note to support (http://wordpress.com/contact-support/) with an example URL of where this is happening.

  6. She told me it's happening on my blog, and I emailed Support on I think Friday. http://raincoaster.com

  7. I also experienced this on rain's blog intermittently but I'm not sure if it was on Thursday or Friday.

  8. I just got an email from England saying that the link to my blog goes nowhere.

  9. I noticed it a few days ago on Raincoaster's and Engtech's blogs. Yesterday I was browsing through some more blogs, and it appears that all the ones that use domain mapping (removing the 'wordpress.' part from the URL) have this problem.
    I'll send in a support request as well.

    Edit: Eh? Support is closed? Surely they can receive email while they're AFK, no?

  10. An email from OMG England? :)

  11. It's not all domain mapped blogs. I just loaded up Raincoasters. Haven't tried anyone elses. I'm too lazy.

  12. I've tried my own blog, Raincoaster's and Engtech's, no problems. Not sure if this is on any of them, but I was wondering if it might have anything to do with the snap preview? I know a few people have complained it's caused problems with pages loading...

  13. I'm not able to reproduce this on raincoaster.com or internetducttape.com. Have you tried this with different browsers, and different machines?

    As for the Snap preview, you can disable that for your blog from the blog admin (Presentation -> Extras).

  14. I had no difficulty connecting with either rain or engtech's domains just now and I know that snap previews were disabled on both of those blogs shortly after their introduction.

  15. I've tried again to view those blogs in Epiphany, and it works just fine there. Firefox however keeps reloading those pages unless I turn off JS. I don't have any other computers here to test with.

    I thought the problem was in the "function addLoadEvent(..." script, because it looks like it has to do with loading the page, but I noticed that it's in the source of the WP.com front page too, and that one loads/displays just fine.

    Could the problem be in the line with script src='http://wordpress.com/remote-login.php?action=js&... ? That one is different from the regular WP.com blogs I think.

    Sorry I can't be more help.

  16. Hmm. Using a proxy server to log HTTP traffic, surfing to internetducttape.com gives these three requests over and over:

    GET http://internetducttape.com/
    GET http://wordpress.com/remote-login.php?action=js&host=internetducttape.com&id=######&back=internetducttape.com%2F
    GET http://internetducttape.com/remote-login.php?login=################################

    Where the ##s stand for (hex) numbers I've removed just in case they're sensitive info.

    Anyone know what to make of that?

  17. i don't have any idea what all that technical stuff is, but i know you have to allow a cookie to be set in order to go to the domain-mapped site. If you deny the cookie (or have cookies turned off), you end up in the loop.

  18. Is that it?
    *removes site from blocked list and tries again*
    *astonished* It works.

    Dang! Does that mean I have to allow cookies from every domain-mapped wordpress.com blog I visit? I hate having tons of unnecessary cookies. *grumble grumble*

    Well, thanks for clearing up that mess Judy. You get today's Awesome Support Forumer award :)

    *off to tell WP.com to cut down on the baked sugar*

  19. Of course (heel of hand hits forehead). Thanks judy!

  20. @judyb12: Hooray! Great work there! Even joseph didn't know what would cause it. :-)

    @kimik0: I feel you on that one. It doesn't make sense to need cookies to simply view the site.

    *off to tell WP.com to cut down on the baked sugar*

    ROFL!

  21. Quoth Joseph @ WordPress.com:

    The .wordpress.com cookie is for the blue menu panel along the top of the page. We've discussed potential changes in the way this is handled, but have no time line for changing it at this point.

    I must say, they are quick in replying.

  22. You're welcome. When's the award ceremony? ;)

  23. Okay, now I need to email the entire world and let them know that the myriad delights of raincoaster.com are only a cookie-allowal away.

  24. not sure why this thread was marked as a resolved, this is a very long standing*, let's say feature, which fortunately does not affects the entire world. yet.

    only _logged in_ wp.com users who want access 'myriad delights' of .com hosted domain-mapped blogs are lucky subject of being an open jar for cookies from external to .com domains.

    quote from Joseph @ WordPress.com to kimik0:

    The .wordpress.com cookie
        ^^^^^^^^^^^^^^
     is for the blue menu panel along the top of the page.

    were it actually a ".wordpress.com" cookie it wouldn't make such a problem: because cookies from this domain are already in the .com user browser white-list (otherwise no login is possible, of course).

    in fact, we can see as a wp.com domain-mapped host wants to send us a cookie for its own domain, which is not allowed by default (what is a Right Default Thing for many reasons). then it probably tries to get it back and fails with a cryptic "Invalid key" message.

    so it's not exactly an original ".wordpress.com" cookie -- it is rather a foreign one from a perfectly stranger.

    no-cookie solution: turn off JS on accessing a domain-mapped .com blogs.

    +++GET 5661+++
    GET /remote-login.php?login=0xbad HTTP/1.0
    Host: changingway.org
          ^^^^^^^^^^^^^^^
    +++RESP 5661+++
    HTTP/1.0 302 Found
    Set-Cookie: wplogin=%%%% path=/; domain=changingway.org
    ^^^^^^^^^^
    Location: http://changingway.org/

    *) I couldn't get to Scobleizer's blog for this matter almost year and half ago.

  25. Well, I reckoned since we found the reason why domain-mapped blogs wouldn't work for me, and WP.com won't fix the problem, I'd best set the topic to 'resolved'.

    Btw, I pointed out to Joseph as well that it wasn't actually a .wordpress.com cookie, but he didn't reply to that part of my email.

    But you're right, the underlying problem isn't resolved, just uncovered. I'll set the topic back to 'not resolved'

  26. > it wasn't actually a .wordpress.com cookie, but he didn't reply to that part of my email.

    "omg, a cookie is from England, not from .com!" ;-)

    the very best and probably most safest way would be to separate '/wp-admin/*' part from a publishing .wp.com into another domain (like 'blogger' vs 'blogspot') that'd also allow to mitigate related security concerns (particularly considering that fact a .com PW is transmitted as an unencrypted plain text over plain HTTP ;-(

  27. I thought the English called them biscuits? ;)

  28. oh, right you are "in Spain they're galletas, Germans call them keks, in Italy they're biscotti and so on."

    and we need a confirmational reply from the tagNotFound(;-) as he's an expert.

  29. hmmm...Those that had issue recently pulling up blogs - did anyone happen to have put the 'quantserve.com' as a site to block just prior to this happening??? That may well cause an issue I suspect.

  30. Yep, quantserve.com cookies are blocked. It isn't ad-blocked though, so images or whatever from there should still download.

    Why do you ask? Is quantserve.com another WP.com blog in disguise? It redirects to quantcast.com, which doesn't look like a blog at all, just another one of those counter sites that always want to track my net.surfing.

Topic Closed

This topic has been closed to new replies.

About this Topic