Need help? Check out our Support site, then


Unwanted left margin

  1. I can't understand why there is a left margin in this page:
    http://testdocns.wordpress.com/listedocs/marrainage/

    (password: docns)

    There is none in the "Accueil" page, I don't understand why both are differents.

    Also, I can't find answers about that kind of appearance problems (like my table borders). Where can I find answers about that coding? I searches in support section and in forums but I can't find exactly what I need...

    Thanks!
    Maude

    The blog I need help with is testdocns.wordpress.com.

  2. 1) That's the way the theme is designed. Compare:
    http://twentytendemo.wordpress.com/
    http://twentytendemo.wordpress.com/about/
    You can switch to a different theme.

    2) You can ask here. For starters:
    • Each regular cell is defined by td tags, not th tags (th tags are for table headings).
    • Commands such as border="3" are outdated and don't work. You need to add styling to the opening table and td tags, for example:
    <table style="border:1px solid #ccc;">
    • What on earth do you want those "espacer" images for?

  3. Is there a list of the accepted styles?

    I think I learned the html too many years ago... I learned to use the spacers images to determine the width of the cells... I feel like my skills are a little low for the use of this tool and I'm a little uncomfortable to use your time like that. Thanks a lot for your help.

  4. Styling isn't HTML, it's inline CSS. To modify the styling of an element, you add the style attribute to its opening tag. The style attribute accepts various properties and values. Check my relevant posts for examples:
    http://wpbtips.wordpress.com/list-of-posts/3/
    The list of properties is enormous - see here:
    http://www.w3schools.com/css/default.asp

    To determine the width of the cells you don't insert images.
    You specify the width of each column like this:

    <table>
    <col width="250" /><col width="190" /><col width="100" /><col width="100" />

    Note that the command you've used for the table width (width="900") has no effect, the default for tables in the theme you're using is 100% width, and the width of your pages in the theme you're using is 640px.

  5. Wow, there is a lot of very useful things in your WordPress tips site, thanks a lot.

    I did a little changes (with a lot of tries) and it's a little easier now, but I still have two problems with my (same) table.

    The text padding seems too big in the cells, I don't want all this "free space". And the change I made in the table style doesn't seems to work. Do I have to do it for each td?

    I would like to have only columns, no row lines and the tag td border:none seems override by the th one...

  6. The root of the problem is that tables used to be 'neutral' unless you specified otherwise, but many new WP themes include some default table styling in their CSS; this means you'll never be able to style a table correctly if you don't examine the CSS of the theme, to find out what you need to change or override. The default for table cells in 2010 is a grey top border, a 6px top&bottom padding, and an outrageous 24px left&right border.

    Here's what you need to change:

    1) Remove these from the opening table tag:
    height:6px;padding:5px;

    2) Remove all of these:

    <h3 style="text-align:left;">
    </h3>

    3) Turn all of these:
    <tr style="border:none;">
    to just:
    <tr>

    4) Turn all of these:
    <td style="border:1px solid blue;">
    to:
    <td style="border-top:none;border-right:1px solid blue;padding:5px;">

    If you need further changes, shoot!

  7. Nice! Thanks (again!)

  8. Is it possible to cancel the automatic title in the static pages? I guess it's there because of the "Twenty Ten" theme I choose.

    The source say "<meta property="og:title" content="Protégé : Gestion" />" Is there any way to override it or to remove it somehow?

    Thanks

  9. Yes it's possible - see here, under "Other options, special cases and tricks":
    http://wpbtips.wordpress.com/2011/12/19/custom-menus/

  10. Hmmm... That works for me, but now, I cannot use de "Pages Widget" correctly, and I still have the word "Protégé" on top of the pages...

  11. 1) You can use a Custom Menu widget instead of the Pages widget.
    2) For a better solution (that would include hiding the word "Protégé") you need the Custom Design Upgrade.

Topic Closed

This topic has been closed to new replies.

About this Topic