Need help? Check out our Support site, then


Upgraded to CSS editor, header gone, i've read all forum posts... still no luck.

  1. My blog http://powerandecstasy.wordpress.com/
    Theme: Fjords04

    everything was fine until I upgraded to CSS editor then my custom header disappeared from the blog though the image still shows in the Custom Header Image page in the Dashboard... so I looked at the forum posts... I uploaded new images, changed their names as directed, added css code... and nothing.

    I've tried background-image: as well as background-color: and no luck either

    here's my latest attempt

    #header {
    background:url('http://powerandecstasy.files.wordpress.com/2007/10/header2.gif');
    }

    before I had

    #header {
    height:200px;
    width:900px;
    background:url('http://powerandecstasy.files.wordpress.com/2007/10/header.gif');
    }

    Some one out there... please help!

  2. I know that once you have edited the css you can no longer use the image uploader to upload a header as you could before. Hopefully a "css" expert will drop in soon and give you a hand with this.

  3. thanks!

  4. I'm no expert but I did encounter this. Simply enter the url of the image. As timethief pointed out, the uploader will not work with the css upgrade.

    btw, theadviceangel, you do know that wp.com blogs can not be used for commercial purposes?

    {wave at tt}

  5. thanks... the url is entered, which is why this is such a mystery.

    and yes, the blog is in progress and is about the wonderful expressions of dance and martial arts.

    thx

  6. You may also find that once you enable the CSS upgrade that all other images that the theme uses are also gone, not just the header image. You may have to go through and edit the CSS sheet to have all the image URL's full path. For example, you may want to try the following for your header image:

    background-image:url('http://powerandecstasy.files.wordpress.com/2007/10/header2.gif');

    Depending on what theme you are using, there is a public theme directory, for example:

    http://powerandecstasy.wordpress.com/wp-content/themes/pub/themename/

    It can be found off the "edit CSS" page by clicking on the "view stylesheet" in:

    Add to existing CSS (View stylesheet)

    As for the commercial content, maybe run it past staff if you are not sure.

    Trent

  7. OMG

  8. Thanks Trent...

    Tried it again with and without the height & width and still no go.

    #header {
    height:200px;
    width:900px;
    background-image:url('http://powerandecstasy.files.wordpress.com/2007/10/header.gif');
    }

    I tried using this image as a background image and that worked... so maybe the css does not recognize "header"... is there another way to set the header like header:image? (I tried that one and it did not work)

    thanks!

  9. What theme are you using? When you view the original CSS sheet (as I described above), what is the exact code it is using for the header ?

    Trent

    *Edit* nevermind....read the original post again! Checking.....

  10. OK..... try this as there is no 'header' in that sheet!

    #content, #sidebar-1, #sidebar-2, #sidebar-3 {
    	background: #ffffff url(http://powerandecstasy.files.wordpress.com/2007/10/header.gif) no-repeat top left;
    	overflow: hidden;
    }

    Trent

  11. Yes! It worked! THANK YOU!!! YOU ROCK!!!!

  12. Glad to get you back going!

    Trent

Topic Closed

This topic has been closed to new replies.

About this Topic