Need help? Check out our Support site, then


Upload mp3s with space upgrade...

  1. Hi there,
    I don't know if there are already other topics that match my problem, however, I didn't find one, so I am asking here:
    I have just purchased the space upgrade and am already able to upload mp3s and other files. However, when I for example upload an mp3 to a page I am editing, give it a name and hit "insert to post", there is only a plain text appearing in my post/page, but not, as I would expect, the wordpress mp3 player... And if I chose "file url" ore "post url", there are only links appearing. What I expected (and read) was that you would simply upload a mp3 file to your post or page and it would appear in this little nice player directly in the post respectivly on the page.
    So am I doing anything wrong or is there a more complicated procedure to get the mp3 played directly in the post?

    Thank you very much for your help!! :-D

  2. I read this one too...
    So does that mean that uploading directly to wordpress is the same as uploading to any other host??
    upload file ==> get the file's url ==> write that [audio xxxxxx.mp3] line? I thought there were some benefits when you purchase the space upgrade.... I always thought you just upload it in your post and the player appears...

    lame...

  3. panaghiotisadam
    Member

    Yes, unfortunately it's the same as uploading to any other host: the upgrade just gives you more space and allows you to upload more file types.

  4. HI-
    I too just upgraded so that I can upload MP3 files to my blog. I managed to upload one file so I guess I did that right. But, when I go to put it in the page, it just isn't working out.

    I read the FAQ's but I must be thick in the skull because I cannot seem to get it right.
    Could someone give me a step by step instruction on how to put the MP3 file which is uploaded already
    into a page?

    The file name is 05-04-08.mp3

    I think I'm getting mixed up when you go to Media Library. It says Title: I put in "Listen"
    Caption: blank Description: blank
    Link URL: Don't know what to put here????
    Below that; None File URL PostURL I don't know what to do with these three items???

    So, please help me. I know I'm just doing some little thing wrong.

    When I get this right; are people suppose to click on my "Listen" and then some kind of player comes up so they can hear it?

    When I go to other sites on the web and click on something to listen to my Windows Media Player comes up. Is that suppose to happen here in wordpress? Or what??

    Thanks
    Bonnie

  5. panaghiotisadam
    Member

    @Bonnie: Click "File URL", and the URL will show up in the box above. You copy it, then go to the post editor and paste it like that:
    [audio URL]
    That's the shortcode formula for the WP audio player.

    Also go to Settings>Media and set "Default media links" to "File", so that for future uploads the URLs will show up automatically.

  6. Thanks for your help but I am still having some problems.

    I got it to work so that you can listen to it, but it is coming up in QuickTime Player instead of WP Player.

    Here is the code: >Listen
    <a class="s1"

    I know something is missing. Can you help me out?

    Thanks.
    Bonnie

  7. panaghiotisadam
    Member

    It's coming up in QT because you have vreated a LINK to the file (as you can see by what showed up here, too). If you want the WP player, you just use the shortcode I suggested in my previous reply. In this case, this is what you should paste in your editor - nothing more:
    [audio http://hatchcreek.files.wordpress.com/2008/08/05-04-08.mp3]

    By the way, if you ever need to show us again some code you've used, put it between backticks (that's what produces the frame you see now), so that we see the code itself and not the result it's meant to produce.

  8. panaghiotisadam
    Member

    Note: in case you directly copy the above, paste it in the html post editor; in the visual editor the player won't work because of the active link.

  9. Okay, I tried that. Why would it when I type in this code,

    [a href="audio http://hatchcreek.wordpress.com/files/2008/08/05-04-08.mp3"]Listen[/a]

    Then I save it, it automatically takes out the "audio http:" part of the above code?

    Is the first code above correct for making the WP player work with my mp3 files?

    Thanks.
    Bonnie

  10. panaghiotisadam
    Member

    I don't know why you insist on experimenting with codes of your own invention.

    If you want the audio player on your post, the code is just what I posted before: square bracket - word "audio" - space - URL of mp3 - square bracket. NOTHING else; no "a href", no "Listen", no nothing. (You'll write the "Listen" in your post editor as a plain normal word above the player.)

    If you don't want the player but a link to the mp3, you just write "Listen" in the visual post editor, highlight it, click the Link icon and paste the URL of the mp3 in the box that opens (the URL is the green part in my 6:51 PM post - from "http" to "mp3").

  11. panaghiotisadam
    Member

    Sorry, "green" should read "blue"!

  12. Hi-

    I'm sorry I was so thick headed. I guess I have a tendency to make things harder than they actually are.

    Thank you so much for your help and patience. I finally got it to work thanks to you.

    Bonnie

  13. panaghiotisadam
    Member

    I'm glad I could help - happy blogging!

  14. Hello-stupid question :) -can I upload mp3's on my wordpress blog without purchasing the space upgrade?And if it is possible..how?Thank u!

  15. No you cannot. Take a look at the FAQ http://faq.wordpress.com/2007/10/18/about-the-space-upgrade/

  16. Help! Do I need to upload files from my desktop to the media library, if so how do I do it?

  17. Thanks so much, I appreciate the reply. I am getting ERROR 404 File not found

Topic Closed

This topic has been closed to new replies.

About this Topic