Need help? Check out our Support site, then


uploaded images do not appear

  1. Images uploaded to my pages do not appear in my blog - the title of the image appears instead
    Blog url: http://foxycomeshome.wordpress.com/

  2. If you delete an image from your Media Library it cannot be displayed. http://foxycomeshome.files.wordpress.com/2012/09/foxy-comes-home-front-cover1.pdf

    (1) Are you trying to upload images into a post on the WordPress.com home page? http://wordpress.com/#!/post/
    Or are you on the dashboard of your own blog?
    http://foxycomeshome.wordpress.com/wp-admin/post-new.php
    The latter is a better choice.

    (2) If you are using an IE9 browser in compatibility mode that makes it render as IE7 and IE7 is not supported. To disable see > http://www.sevenforums.com/tutorials/1196-internet-explorer-compatibility-view-turn-off.html
    a. Have you tried clearing your browser cache and cookies ? http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=32050
    b. Have you tried updating the browser to the latest stable version? http://browsehappy.com/

    (3) For details about the options for uploading images see:
    http://wpbtips.wordpress.com/2009/04/26/images-the-three-link-options/

    (4) For troubleshooting images tips see > http://en.support.wordpress.com/images/troubleshooting-images/

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags