Need help? Check out our Support site, then


Uploading Images through Add Media Button No Longer Working

  1. I am no longer able to insert media/add media into a blog post. I always had no trouble doing it in the past, and this is happening on any/every computer I try it from now. Now, it says, Add Media/ Upload Files and then in the middle of the page instead of just saying select files, it says "or" select files and when I click it doesn't work. I have done everything the guidelines/support tell me to as far as clearing cache and cookies. I am not full on disc space. It simply won't allow me to upload images at all. All I can do is go to my current media library and choose from images I have already saved there. This is awful as I need to place images in my blog posts. Any help you can offer me would be appreciated. I have done every single thing the support guidelines say to do on three computers. I am checking today on another computer, and it's the same situation.

    The blog I need help with is ambirkelo.wordpress.com.

  2. In order to help you we need to know your specific computing environment details. Please work through what follows and report back.

    1. If you are not running one of the browsers and versions listed at http://browsehappy.com/ please try upgrading or switching first.

    2. If you are using an IE browser in compatibility mode please disable that mode. http://www.sevenforums.com/tutorials/1196-internet-explorer-compatibility-view-turn-off.html

    3. If you are running one of the browsers and versions listed at http://browsehappy.com/

    (a) Try clearing your browser’s cache http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=32050

    If applicable see here for instructions on how to clear the cache for Chrome and Safari on the iPad:
    http://browsers.about.com/od/howtousemobilebrowser1/ss/safari-ipad-clear-cache.htm
    http://browsers.about.com/od/howtousemobilebrowser1/ss/How-To-Clear-Browsing-Data-In-Chrome-For-Ipad_6.htm

    (b) Make sure that you have both third-party cookies enabled and JavaScript enabled
    http://en.support.wordpress.com/third-party-cookies/
    http://www.google.com/adsense/support/bin/answer.py?answer=12654

    (c) Disable all browser extensions or add-ons temporarily.

    (d) Try enabling HTTPS: http://en.support.wordpress.com/https/

    Add both *.wordpress.com and *.wp.com to your list of trusted sites under the Security tab. Make sure to uncheck the box for “Require server verification (https:) for all sites in this zone.” http://en.support.wordpress.com/https/#frequently-asked-questions

    4. You can use this link to see if your flash is up to date. http://www.adobe.com/software/flash/about/ If it’s not then go to http://www.adobe.com/products/flashplayer/ and download and install the latest version of flash.

    5. Try using another browser.

    6. If you are not successful let us know:
    (a) Exactly what kind of device you are using to connect to the internet and to WordPress.com.
    (b) Exactly which browser (and version of it) you’re using by checking here if necessary http://www.whatbrowser.org/
    (c) Exactly what you experience including what any error reports you receive state.

  3. Me too tho I get a bad gateway error on a mobile app

  4. @evette77
    Please go back to your original thread here http://en.forums.wordpress.com/topic/bad-gateway-error?replies=2#post-1990014 that's tagged for Staff and do NOT post into any other threads.

  5. I have the same problem. Uploading Images through Add Media Button No Longer Working

  6. @pompilo
    What exactly are your browser and connectivity details?
    See here http://en.forums.wordpress.com/topic/uploading-images-through-add-media-button-no-longer-working?replies=5#post-1989998 and report back please.

  7. abirkel1 - I have exactly the same situation. Here are some temporary ways around:

    1. If you want to post a picture posted somewhere else, "insert media" using the "from URL option.

    2. Upload your picture to Google Drive, Flickr, or any similar space that allows you to use url to your media and then "insert media" using the "From URL" option.

  8. To timethief - I see you guys are suggesting upgrading to more "modern" browser. I don't understand this. If my uploads with my older IE 9 browser in Windows Vista worked just fine until two weeks ago, then it is not the browser that is the problem but some changes WordPress has made at its end. I can only guess why such changes were necessary, since everything had worked just fine before, but I don't like the idea of upgrading to "better" browsers because I don't know what they are better at. Maybe spying on me? Possible, in todays crazy world. I don't like it. Please make things the way they used to be.

  9. @everyone
    Please note that I have tagged all thread reporting this same issue for Staff intervention I asked questions above to get the information back that Staff need to know. Please act on what I reported so that specific browser and connectivity related information is available to Staff when they work their way forward to this thread. Otherwise you are wasting your own time because they will asks all the same questions, and more besides, such as whether or not you have had a recent security program or firewall update.

  10. @kozidryngiel

    If my uploads with my older IE 9 browser in Windows Vista worked just fine until two weeks ago

    IE9 is an outdated browser version that was released in 2011. Yes it worked before. No it does not work now. The browsers and versions of them that are supported are at http://browsehappy.com.

  11. Hey everyone,

    We're experiencing some issues with image uploading particularly in IE. Thank you all for your help so far in troubleshooting this issue. We're going to use this as the main thread for this issue going forward.

    If you're having trouble with image uploading, could you let me know the following to help troubleshoot?

    1. When you're uploading images, are you uploading to the WordPress.com Editor or to your Dashboard? The URL in your address bar will help you tell the difference:

      WordPress.com Editor - http://wordpress.com/post

      Dashboard - http://jeremeyduvall.wordpress.com/wp-admin

    2. Can you try another browser like Google Chrome or Mozilla Firefox?
    3. Can you try updating your version of Internet Explorer? You can find up-to-date browser versions at browsehappy.com.

    We'll keep this thread updated with additional information.

  12. I find that the Select Files button doesn't do anything when I'm trying to upload an image while editing a post, but I've found a workaround.

    If you go to Media > Add New there's a “try the browser uploader” link which does work. (This option isn't visible when inserting media from within a post.)

    Then you can go back to the post you were editing and add the image from the media library.

    The problem occurs for me when I'm using the dashboard in IE9. Other browsers are fine. I'm using a work computer so am unable to upgrade IE.

  13. I'm using the dashboard in IE9

    IE9 is an outdated browser released way back in 2011 and the latest version is IE 1. Please upgrade your browser version to IE11 or download and use another browser and version found here http://browsehappy.com.

  14. I was trying everything I could think of to upload images, using IE (and not the latest version, either). Thanks to your tip, I tried it in Chrome, and it works! :-D

  15. @bethchepita
    You're welcome and best wishes with your blog.

  16. I am using Chrome and everything is pointing to wordpress.com which keeps me from choosing a featured image and also I don't have the option to choose different types of gallery displays... :(

  17. Exactly which and version of Chrome are you using? Check here please http://supportdetails.com

  18. Chrome 36.0.1985.125

  19. Thanks for posting the version number for Staff, John.

  20. Hi @johnwilbanks,

    It sounds like you're using the new editor at wordpress.com/post. Is that correct? If so, the features you mention (editing galleries and setting a featured image from your media library) are not available there just yet.

    To access these features you'll need to edit a post from your Dashboard. You can find your Dashboard by using yoursitename.wordpress.com/wp-admin. From that screen, click "Posts" and then "Edit" underneath the post you would like to edit.

    Featured images and gallery editing are two issues we're looking into with the new editor!

  21. I'm shocked that you are doing no better than "looking into" providing these essential features in your new editor.

    You had no business foisting this new editor off on your users with such important features missing.

  22. I am a brand new user trying to load photos for the first time. I tried in the dasboard mode and am using IE 9. I see from this site that IE9 is no longer supported and will try another browser. Though IE 9 is outdated, I need to stay at that version to run other programs. Let's see what happens when I try Firefox or Chrome..

  23. Thank you Fulhamso!!!!! YOU are a lifesaver! I can finally upload a photo! Amazing how I have had such a run-around up until I read your solution. Bravo to you!

  24. @fulhamso
    Thanks a lot. It's a late procedure but it works!

  25. But in the long run for anyone using an outdated browser, and in IE's case that's anything below IE11, the web is moving on and so should you. Try Firefox or Chrome, both of which work on older operating systems.

    http://browsehappy.com/

  26. When I insert a photo where my cursor is, the photo inserts at the top left instead of inserting where my cursor is in the text. I use FireFox 16.0.2 on "release update channel." I'm on my dashboard paulacappa.wordpress.com/wp/admin/post. I'm on the post page, Visual tab which is where I always compose text and add photos. I don't have Explorer or Chrome. Any suggestions? What's changed? All was fine a week ago. Paula Cappa

  27. I am posting here at the request of timethief.
    I am using a Macbook Pro (OX 10.7.5) with Mozilla Firefox (31.0) and I'm unable to set new featured images for individual pages in Twenty Ten. I have followed all of the above advice (clearing cache, disabling add-ons, securing through https, etc.) to no avail.
    I imported this site from a previous wordpress.com site of mine that works perfectly. However, I want to preserve that old site and make modifications on the new site. Please help!

  28. Please, don't send me more emails.
    Thank you

  29. @pompilo-If you subscribed to this thread, you will have to unsubscribe to stop receiving emails. You can do so at the bottom of every email notification you receive or from the sidebar here in the forums.

    Cheers.

  30. When you're uploading images, are you uploading to the WordPress.com Editor or to your Dashboard? The URL in your address bar will help you tell the difference:

    I am uploading via the dashboard: https://barbaramolony.wordpress.com/wp-admin/post.php?post=6178&action=edit&message=10

    Do you have success with another browser like Google Chrome or Mozilla Firefox?

    I am using Firefox, as I always have. Half way through a post I started yesterday without problem

    My browser is up to date

»

You must log in to post.

About this Topic