Need help? Check out our Support site, then


Upload/Insert Media not working

  1. Try to click on Upload/Insert Media, but nothing happens. Anyone else having this problem?

    The blog I need help with is christennantphotography.wordpress.com.

  2. These are the troubleshooting steps we take whenever any issues like this arise:
    clearing your browser cache and cookies > http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=32050
    using the browser with all extensions or add-ons disabled
    updating the browser to the latest stable version (not a buggy BETA browser version) http://browsehappy.com/
    confirming third party cookies is enabled http://support.google.com/accounts/bin/answer.py?hl=en&answer=61416
    confirming JavaScript is enabled http://www.google.com/adsense/support/bin/answer.py?answer=12654
    confirming Flash is updated http://www.adobe.com/software/flash/about/ and if required installing the latest version of Flash http://www.adobe.com/products/flashplayer/
    resetting your router and modem and rebooting your computer
    then logging in using the secure https:// log-in see http://en.support.wordpress.com/https/
    trying another browser

    If those do not work for you then we need to know
    (1) how you are connecting to the internet and to WordPress.com. The way you connect to the internet (mobile, satellite, DSL, dial-up) and to your blog, and how many proxy server jumps etc. it takes to connect can cause problems. There maybe be problems with your ISP and/or with the proxy servers. Also note that the main dashboard isn’t designed to work with touch devices through the tablet and smartphone browsers.

    (2) exactly which browser and version of it are you using. If you don’t know click here to find out > http://whatsmyuseragent.com/

  3. I've done almost all those steps. What is peculiar is that I cannot Upload/Insert "medial" or "make new poll" but it will allow me to create a "custom form" (the third icon to the right).

  4. If you are not using the https:// secure log in please try it.
    http://en.support.wordpress.com/https/

    If you are using IE9 in compatibility mode disable that as it reduces the functions of the browser to IE7 and IE7 is no longer supported.

    If you are running Adblock please try disabling it.

  5. Blah. I give up. It should not be this difficult to upload a simple image. Will try from a different machine later. Appreciate your help.

Topic Closed

This topic has been closed to new replies.

About this Topic