Need help? Check out our Support site, then


Users are not importing

  1. When I import from another WordPress site posts, categories and tags are imported, but users are not imported. Posts are all assigned to the same admin user.

    I've modified the XML to include only a single post and to ensure that none of the users has duplicate email or username with the existing user. I've also ensured that no usernames have uppercase or non-alpha characters.

    Here's a sample of the XML I'm importing: http://plccorg.wordpress.com/sample-wordpress-export-xml-for-import/

    Any ideas what else could be going wrong?

    The blog I need help with is plccorg.wordpress.com.

  2. As far as I know the users are not export/imported. You have to add them manually.

  3. Is that unique to wordpress.com? I see forum posts on wordpress.org that reference the ability to import users along with posts:
    http://wordpress.org/support/topic/authors-not-importing
    http://wordpress.org/support/topic/plugin-wordpress-importer-wordpress-importer-problem-all-posts-author-become-admin
    http://wordpress.org/support/topic/invalid-author-importing-single-wordpress-to-mulitsite-wordpress

    Also, during import into my wordpress.com site, I'm presented a list of all users in the xml file with an option for each labelled "Import author: <username> (<username>) or assign posts to an existing user:". Of course <username> is populated with each user in the file. Why would it give me the option of importing those users *or* assigning to an existing user if user import was not supported?

    Thanks for any help you can provide!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.