Need help? Check out our Support site, then


Using Images As Links...?

  1. Someone had already posted this question here before, but I didn't quite understand how to do it. Could someone please explain to a non-techie how to go about using an image as a hyperlink?

  2. Well, if you are only talking about creating a hyperlink of an image in one of your posts, this is the procedure.

    1) Upload your photo using the upload box below where you type text. Browse to the file on your computer, enter information you want for description and upload it.

    2) Send the photo to the editor that you want hyperlinked. Highlight the photo in the editor by clicking on it to select it. Choose the insert/edit link box in the toolbar. Enter the link URL you want!

    3) Your image is now hyperlinked!

    If you are talking about images for your blogroll, you just add a new link in the blogroll section, choose the 'advanced' tab at the bottom of page and enter the URL of the image that you want the link to be.

    If you are just talking about hyperlinking an image in say a 'text widget', the format of the html would be:

    <a href="http://www.yourlink.com"><img src="http://www.yourimage.com/yourfile.jpg"></a>

    Hope that helps you along!

    Trent

  3. lol! Nevermind...I figured it out on my own:

    First use the insert/edit image button (the button with tree on it) to insert the URL of the image.

    Once you've inserted the image, click on it and select the insert/edit link button (the one with the chain link). Put the URL of that link in there and press "Update".

    And...tada!!! Instant photo/hyperlink!

  4. LOL! Thanks Trent. You posted your reply at around the same time as mine own!

    Thanks!

  5. Doh! (blushing) I still don't get it - can someone take me through it from here. My blinkie is in the sidebar - in the text widget I have my url links to the blinkie and they are flashing away OK on my blog. Now I want someone who clicks on the blinkie to go to a link, with the text box open I can't figure out how to url link to my url picture. What am I missing?

  6. <a href="http://www.the-location"><img src="where the image is" /></a>

    That's the structure.
    So if I wanted to link to wordpress.com with an image I had uploaded:

    <a href="http://wordpress.com"><img src="http://mark.files.wordpress.com/2007/03/cal.png" /></a>

    That help?

  7. Sorry, see next post.

  8. I've been battling all day with this. I put in the following:
    <a target="_blank" href="http://www.ipcst.org/Taquara" title="Taquara Gallery"><img align="left" src="http://ipcst.files.wordpress.com/2007/05/_asc2134.jpg" alt="Taquara celebrations in Kuikuro" /></a>
    I save the post. I view the post, and it seems OK. I try to access it a few minutes later, and the picture is gone! So I go to 'Edit Post' and the code has changed to:
    <a target="_blank" href="http://www.ipcst.org/Taquara" title="Taquara Gallery"></a>; the code relating to the image has disappeared. The images are there to browse, and if I view the site from the editor it looks fine at first. What's happening? Help!

    Patrick

  9. This is a recurring error, nobody can find the reason for it at the moment and Support is closed for the weekend. What I suggest is composing the widget in the normal Write Post box, previewing it to ensure that it worked, copying the code, and pasting it in the widget. There's no particular reason that would work better, but it might. This is a weird, touchy error. Try it and let us know.

    I'm thinking that so far it only seems to happen with WordPress.com-hosted files. Perhaps if you have a Flickr or Photobucket account you could try hosting the image there?

    In the meantime, I wouldn't make any widgets with images until Monday, when support is open again.

Topic Closed

This topic has been closed to new replies.

About this Topic