Need help? Check out our Support site, then


Vanishing Images

  1. Why do my images disappear from some posts days or weeks after I've put them up? What can I do about it?

    The blog I need help with is marcys.wordpress.com.

  2. thesacredpath
    Staff

    We need a link to a place where this has/is happening in order to check things out.

  3. I'm having the same problem with some of my inserted photos as well. It was even happening as I was writing a post.

    http://terii.wordpress.com/

    The first image in my latest published post is missing as are some in earlier posts.

    Thanks!

  4. thesacredpath
    Staff

    First off since your blog is quite image intensive, my suggestion is to set your blog to display only 3 posts per page (settings > reading). If your internet connection is a little slow at times there can be timeout issues especially when you have so many images.

    I see all the images on your main page just fine.

  5. Hello. Something similar is happening to me, too. Some images seem to have "disappeared" from my posts. In fact, they're still there, but they are not being exhibited by the browser... however, they are in my media library. It is possible to see these images through their link, but they are not being displayed by the blog. Anyway, I have tried to see these posts in different browsers, but it didn't work.

    After reading your advice, thesacredpath, it seems to make sense. I'm having some troubles with my computer memory... Apparently, my RAM memory seems to be not enough to process data. I will try to reduce the number of posts being displayed to 2 or 3. I hope it works. Thank you.

  6. Oh, another curiosity: I'm having problems with posts with 3 or more images.

  7. thesacredpath
    Staff

    Clear your browser cache and then force reload the page. Some browsers will hang onto and use cached image files tenaciously - IE for one. On one of my blogs images went missing and I cleared by browser cache and force reloaded the page and they came back.

  8. Unfortunatly, it doesn't work. I have cleared the cache of both browsers - Firefox and IE - but the error seems to persist I really think it has to do with the computer's memory size (Virtual? Low memory, maybe?) Well, in fact, I have 512 MB of RAM memory size, what is not that low... but since I have formatted my computer, I'm encountering errors.

    On the other hand, at least people say that the images are loading normally.

    the sacredpath, thank you for your help!

  9. @vertebrado, You're welcome. If you had provided a link to your blog, we could have taken a look.

  10. Oh, I'm only encountering errors in posts with many images, such as this one: http://axolote.wordpress.com/2009/07/13/portraiture/ .

  11. That post and its images load fine for me.

    Whatever the problem is, it seems to be confined to your computer.

  12. thesacredpath
    Staff

    @vertebrado, I'm seeing the images fine as well.

  13. This problem started for me yesterday. Symptoms are:

    1. Image does not appear in post. An invisible box is there, sometimes with the name of the image file. The box acts just like a normal image link and takes you to the correct image.

    2. Image will not hold correct position both in editing and in the final published post.

    3. Problem is very inconsistent. I have tried resizing and realigning the image, etc. It will appear correctly, but will be wrong the next time I load the page. I have tried it in FF and IE.

    4. Problem does not seem to affect images posted before Aug 2.

    I have posted screenshots showing the incorrect position problem here:\

    http://poligraphic.wordpress.com/screenshots-image-problems-aug-3-2009/

    I do not have a screenshot of the invisible image problem yet. If it shows up again, I will add it to this page.

    It is very easy to see this problem but I have not found a way to reproduce it consistently. Clearing the cache and reloading the page, logging out, exiting the browser, etc. do not solve it. My suspicion is that it is a bug.

    Hope this helps, gang

  14. All of your images loaded just fine for me, so I have no suggestions other than to contact staff directly and report it. Doesn't look like you're the only one with image problems lately that are intermittent.

    http://support.wordpress.com/contact

  15. thesacredpath
    Staff

    It is I think a code issue.

    First off, go to settings > writing and select "WordPress should correct invalidly nested XHTML automatically" and then click save changes.

    On your latest post, there is a position: absolute; declaration, and that should be taken out. This is the code you have for your image:

    <a href="http://poligraphic.files.wordpress.com/2009/08/baucus.jpg" style="position: absolute;">
    <img class="alignleft size-medium wp-image-1611" width="200" height="300" alt="baucus" src="http://poligraphic.files.wordpress.com/2009/08/baucus.jpg?w=200&h=300" title="baucus"/>
    </a>

    Remove the style="position:absolute;" from the href section.

  16. thesacredpath
    Staff

    It is that way in these two posts:

    http://poligraphic.wordpress.com/2009/08/04/my-people-say-no-health-care-plan-for-your-people-pal/
    http://poligraphic.wordpress.com/2009/08/01/insuring-the-health-of-the-health-insurance-industry/

    If you are adding the position absolute, don't do that. If you use that property and value, the image will not retain its proper relationship to the rest of the elements in the post.

    From W3C:

    Generates an absolutely positioned element, positioned relative to its containing block. The element's position is specified with the "left", "top", "right", and "bottom" properties.

  17. I have changed the XHTML setting but it isn't showing any improvement--yet.

    I tried several times yesterday to delete the style="position:absolute;" since it looked incorrect to me, but it is being inserted by WP. If I delete it it just reappears.

  18. That should definitely be reported.

  19. thesacredpath
    Staff

    I just switched to the journalist, inserted three images and it never put "position:absolute;" into the code. I even inserted your image into my post and no position:absolute;

    You can see it here: http://flippintestblog.wordpress.com/2009/08/01/thickbox-image-test/ .

    I even took your code, with the position absolute in it, pasted it into the HTML tab in my post, removed the position:absolute; and then saved and it did not put it back in.

  20. To make sure I wasn't completely crazy I just tried it again. I removed the position:absolute on the image edit screen advanced tab. It reappeared. I then edited the HTML directly. It reappeared. And the image is still overlying the text on the edit screen and the post itself.

    Any idea what the source of this could be? How could something on my end be inserting styles into WP?

    In any case, I'm off to bed (no doubt to have strange dreams about poorly-nested XHTML)

    DM

  21. I am wondering if it has something to do with using the Caption code vs not using it. I generally strip it out, and ALWAYS on a blog with Custom CSS. I've noticed it has some weirdly random alignment control effect you can't override most of the time until you strip it out.

  22. thesacredpath
    Staff

    With the post open in the editor, edit the image, go to the advanced tab, remove the position:absolute; and then at the very bottom of that window click "save changes."

    Delete the image from the post and reinsert it, click the update post button and then after it saves, check the HTML.

    The thing is, the position:absolute; if it were to be used, should have been in the img src section of the code, not in the href section.

    I cannot reproduce the error so I have to believe it is something on your end.

  23. I had the same problem yesterday with 3 images. I ended up making one of them smaller. That seemed to fix the problem.

  24. With the post open in the editor, edit the image, go to the advanced tab, remove the position:absolute; and then at the very bottom of that window click "save changes."

    Delete the image from the post and reinsert it, click the update post button and then after it saves, check the HTML.
    -----

    OK. This works fine. The HTML is fine in the post editor and in the post itself..

    BUT in the editor if I switch from HTML to visual mode and back to HTML the code has reappeared. The effect of this is once again to make the image overlay the text in the editor and if I update the page the code is included.

    Note that the position:absolute code is always present in the image editor advanced tab under Advanced Link Settings/Styles regardless of whether I have deleted it or not.

  25. So the workaround is to be aware that the offending code will reappear during editing and to manually remove the code before updating the post.

  26. It has happened briefly with me too. But clearing the browser cache had helped.

  27. Today,images are loading fine. No problem anymore.

  28. I tested this problem several times since my last post. It may be resolved. The 'position:absolute' code is no longer being inserted into the 'a href' tag and no longer appears in the image editor advanced tab under Advanced Link Settings/Styles.

  29. robertakedzierski
    Member

    Let me preface my comments with the fact that I know nothing about coding!

    I have posted a story today http://robertakedzierski.wordpress.com/ entitled Lovely Lavena on Lake Lugano. It's basically a picture story containing 22 images (each max. 100K).

    I can see it perfectly, using Firefox 3.0.13 on Mac 10.5. On my other computer, though, which uses Mac 10.3.9 and a lesser-quality Firefox, I can read the text and see blanks for the images. I tried using Safari and there was no improvement.

    It could be that the way I created this file is a little crazy. (Don't ask.) I downloaded the pix to iPhoto, I then created the document with long captions using the email facility, which I sent to myself on gmail. And it looked fine. I then loaded that into Google Docs. Which also looked fine. I then posted it to a web page and also used the Google Docs facility to upload it to WordPress.

    That said, if I can see it -- and it looks great, even tho I say so myself -- why can someone else, attempting to access it on another computer be unable to?

    Pls advise.

    Thx

    PS The reason I tried using the google docs route etc, was because I had uploaded some images previously to my husband's blog http://mikesnyder.wordpress.com/ and although I could (and can) see all 44, a friend reported he could see only one.

    Question: Is WP not suited to images? to images of this sort? should I go elsewhere? Thx

  30. This is the "URL" of the first image I see in the latest post: https://mail.google.com/mail/?ui=2&ik=5314dbae22&view=att&th=1231e9acf218ff7f&attid=0.11&disp=emb&realattid=0.1.2&zw

    That will never work since you are asking wordpress to access your gmail account to get the image.

    You need to upload the image directly to your media library here, or to some sort of file sharing service on the internet (and why do that when you have 3gb of upload space here for free?

Topic Closed

This topic has been closed to new replies.

About this Topic