Need help? Check out our Support site, then


Very slow typing and slow Dashboard

  1. Hi

    I've been experiencing a several slow typing issue when I'm writing a new post with the graphical editor, specially when I delete some letters, it could take one second to delete each letter. Also, the navigation over dashboard is quite slow.

    I'm using Firefox V4.0.1 right now. I don't know if the typing problems are caused about the lot of widgets at write screen (by the way, how to disable them?) but it make impossible write a long article, it's very painful.

    Have someone the same problem? How to fix it?

    Probably you will say it so, yes, with Google Chrome it goes well, but I'm using Firefox :)

    Thanks!

    The blog I need help with is elasobine.wordpress.com.

  2. At least we know it's limited to your Firefox, but I'm not able to reproduce the trouble myself. Are you running any add-ons with Firefox? If so, can you try disabling them?

    Also, you can disable Dashboard widgets via the Screen Options tab near the top-right.

  3. Test results:
    I cleared firefox cache. Didn't work
    I disabled all plugins one by one with a reset (needed) between each one. Didn't work. From now, all the plugins are disabled.
    I tried to deactivate most of the widgets at writing window and get a bit better response, but still too bad.
    I hide all the elements of the left-panel menu and performance increase another bit more, but still very laggy at delete text.
    I started a new completly clean session of Firefox. Didn't work, still laggy.

    At full-screen mode the editor goes quite good, the same case like of the editor that you can put at your bookmarks dragging one element of the dashboard (I don't know the name, sorry). It looks that with a "minimalist" interface works fine.
    I forgot to say that with html-editor it works fine too.

    Some other idea?
    Another question, There's some way to make Dashboard more lightweight? (maybe disabling some effects or somethin)

  4. The Dashboard is really about as light weight as it can get once you collapse the sidebar and disable unnecessary widgets.

    It's odd the FF is doing that for you. :( Are you on a fairly old computer?

  5. Well, I'm running an i5-430M with 4GB of ram and ATI Mobility Radeon HD5470 (it's a few months laptop), so probably it's not the problem. I have the system clean as I can, so the system it's not overloaded too.

    I agree that the problem it's very weird :( It works well with Chrome, and even with IE!

  6. At this point, the only other thing that I can think of would be to reinstall Firefox.

  7. Slow internet speed i think OR

  8. Reinstallation it's the last way, so I have been playing with some options at Firefox and I found something that can fix temporaly the problem.
    I activated again all the plugins and started to play with some advanced options. I discovered that if I disable the hardware acceleration everything goes very good, but there's a bit lag while deleting a lot of characters (by keeping down delete key), but it's very less compare to have the hardware acceleration activated (at cost of processor become hotter).
    The problem persist at some pages like Google Traductor (it have a real-time transaltion so it will need more resources, thought)

    In any case, I will try to clean all history, cookies, and everything and looks what happend (that works for general slow problem with older version of FF). If that doesn't work, I'll try to reinstall.

    I'll show here the resuslts of the tests.

    Thanks for the help :)

  9. @pichsopheak, I have 12MB bandwidth (with 1MB of upload), so I think that this isnt' the problem.

  10. Ok, nothing worked. Even the hardware acceleration don't fix the problem, there're times that all goes slow again.

    This's frustrating...

  11. No luck with the reinstall either?

  12. Nope

  13. Hm, puzzled. :(

    I know Firefox 4 is prone to slow-downs overall (not just here) when the history database gets way too large, and I have seen that before on both my Mac and PC, but you have already cleared that.

    Do you have any other third-party security software or firewalls that could be interfering?

    Also, could you check on a different computer?

  14. I only have installed Avast! Antivirus and Windows Firewall should be running over there, but any extra software. But if the problem are caused due to a third-party software, why can IE and Chrome run fine?

    I tried to test the problem in a desktop computer with a single-core (AMD Athlon 64 3400, 1.5GB ram, Geforce 7600GT) and I encounter two situations. At ubuntu 10.40 with Firefox 3.6.13 it works fine, but at Windows 7 with Firefox 4 it's the same problem.

    I ran out of ideas about what could be causing the problem. I can only think that could be a problem of WordPress with Firefox or a Firefox problem rendering something, but I really don't know.

  15. Unfortunately, I can't reproduce the problem on Mac OSX 10.6.7 running Firefox 4.0.1 and Windows Vista running Firefox 4.0.1, so I'm really running out of ideas.

    It's hard to pinpoint the problem without physical access to a computer displaying the issue, so at this point all I can suggest is that the problem is limited to just you in some way, though perhaps WIndows 7 could be the key.

    Was the original problem computer also running Windows 7? Also, can you try with Avast and the Firewall temporarily disabled?

  16. Disabling antivirus and firewall doesn't wotk.
    The original computer it's running Windows 7 Home Premium (64-bits), it's the system that comes with the laptop by default.

    The most useful trail that we have it's related to the hardware acceleration, because when I disable it, wordpress looks to work fine instantly, but other pages get some performance down.

  17. Ok, so the only two key factors here are hardware acceleration and Windows 7.

    Unfortunately, I can't test that myself, but let me see if I can track down someone who can.

  18. Well, more testing.
    After reinstall ATI drivers (lastet version, 11.5) the hardware acceleration performance increases a lot, but not at wordpress, I refer to that page
    http://ie.microsoft.com/testdrive/Performance/FlyingImages/
    I get 60fps constant after install the drivers. That's the fun with ATI drivers, all looks to works fine until you reinstall them, and get that everything goes better!

    Coming back to wordpress, I got that the problem could be at visual-editor. Maybe visual-editor with dashboard together. I think this because if I switch to html-editor at dashboard everything goes fine. Same case at full-screen mode and accesing to new post from that link (that's the editor that I refer yesterday and which name I don't know. Let's say it "press-this" mode or editor)

    http://nameofyourblog.wordpress.com/wp-admin/press-this.php

    So, if I'm editing with full-sceen mode, html-mode or "press-this" mode all goes ok, but with visual-editor it's horrible. Visual editor and Firefox, of course.

  19. One of my colleagues has a Windows 7 machine (ATI 6550M, Direct3D 10) and tried with Firefox 4.0.1 running with hardware acceleration on, but he was not able to reproduce the problem either.

    Please see this guide to find out if hardware acceleration is truly enabled and FF can sometimes disable it automatically: http://blog.mozilla.com/joe/2010/11/10/how-to-tell-if-youre-using-hardware-acceleration/

    If it's still running, I'd have to say at this point that you either still have a drive problem, or worse yet some defective hardware.

  20. I just wanted to chime in saying I'm having a similar problem - I'm running Windows 7 and Firefox, and I'm getting some laggy typing in the post-typing window plus other slowdowns. I'll run through the options presented in this thread, but I'm definitely having similar issues.

  21. snwidget, are the slow-downs specific to just here, or are you noticing them on other sites as well?

  22. Just on WordPress (that I've noticed so far), just on the visual editor, like the original poster mentioned. It's only really noticeable when I try to backspace over things - it seems to take forever.

    The reason I'm really noticing it is that my laptop is brand new, and it's the first time I've composed a post from the new machine.

  23. Does your laptop also have an ATI card? If so, are the drivers up-to-date? Some updates may have been released since your laptop left the assembly line.

  24. I've got an NCIVIDA NVS 4200M card, and everything is up to date. According to the check you posted above, Firefox IS using hardware acceleration.

    I tried using the html editor like the original poster suggested, and that seemed to get rid of the problem, but the normal editor was still slow. When I went to check my publishing options and type something in the "publicize" window (where you push to Facebook or Twitter), typing in that box was incredibly slow as well.

  25. My colleague did some more in-depth testing and we found that there was approximately a 10 millisecond lag with each backspace.

    His computer is quite powerful, so this lag could certainly magnify on slower computers.

    I've passed this up the latter for further evaluation.

  26. Hi snwidget!
    Have you try to disable hardware acceleration while you're at visual editor? As I said up here, it should ""solve"" the problem (note double quotes :). Can you try it?
    Also, have you tested another browser?

    macmancx just for curiosity, which computer have your colleage?

  27. Oh! I miss to say that hardware acceleration is enabled according with the link that you post macmanx.

  28. Yes - hardware acceleration is enabled.

  29. Another fact, the problem it's only at visual-editor text box. There's no problem at tittle, categories and labels text-boxes.

  30. I also get it on the "publicize" text box where you can type in what you want your post's title to look like in Twitter and Facebook.

Topic Closed

This topic has been closed to new replies.

About this Topic