Need help? Check out our Support site, then


Visual Editor has vanished

  1. txcowboydancer
    Member

    Help!!!! I give up.

    The visual editor / HTML tabs are gone. I'm locked into the HTML View. The problem exists whether I'm trying to create a new post or edit an old one. The problem also exists on the "edit pages" screen.

    Here is what I've done so far:

    1. Checked in different browsers -- same problem exists in all browsers I tried: Firefox, Chrome, Opera, Safari. (I refuse to use IE) Firefox is my main browser that I use. The others are there just to troubleshoot and make sure my blog looks good in other browsers.

    2. Updated Java.

    3. Turned off all my plug-ins / extensions and turned them one by one back on.

    4. I use the Mystique theme. Thinking it might be a corrupted CSS file or something like that, I changed my theme to several others and then changed it back to Mystique.

    None of these things have worked.

    One weird note: If I click on the "New Post" button on the toolbar (here is the link that button activates: http://wordpress.com/#!/post/) then the WSYWIG interface is there.

    But if I create or edit a post or page from the dashboard where it calls the links that have .php

    http://txcowboydancer.wordpress.com/wp-admin/edit.php
    http://txcowboydancer.wordpress.com/wp-admin/edit.php?post_type=page

    Then there is a problem.

    This leads me to think that the problem is with the edit.php command(?) file(?) script(?)

    I don't know what the .php means.

    *SIGH* HELP!!!!

    Any ideas? Suggestions? I just want my WSYWIG back!!!!!

    The blog I need help with is txcowboydancer.com.

  2. Thanks for including notes about what you've tried so far! Sorry I didn't find this note sooner. Looks like it was misfiled under the CSS forum.

    The visual editor icons are indeed working for me when I test, and I know they're working for other people, so continuing to try to narrow down what might be causing the problem in your case specifically. When someone reports an issue like this that happens in several browsers in one location but doesn't happen to other people, it's usually caused either by a problem with the local network (i.e. somehow some of the supporting files that makes those buttons display is getting blocked by your network) or sometimes it's caused by anti-virus or firewall software blocking something it shouldn't.

    2. Updated Java.

    This shouldn't matter.

    . Turned off all my plug-ins / extensions and turned them one by one back on.

    This was a good step to try. Did you check anti-virus and firewall software as well?

    4. I use the Mystique theme. Thinking it might be a corrupted CSS file or something like that, I changed my theme to several others and then changed it back to Mystique.

    Very unlikely, since the CSS for the visual editor is separate from the CSS for a theme.

    If you are still experiencing trouble with this, here are a few things you can try:

    1. Try an alternate computer if you have one in the same location. If another computer works, then the issue is computer settings on the first one.

    2. Try an alternate location. If it works, the issue is with your local network.

    3. Check to make sure there are no rules in your anti-virus software or local firewall blocking things from wordpress.com or wp.com domains.

    4. Sometimes re-booting the router helps (kind of a shot in the dark, but I have heard others report success with it in some similar cases in the past).

  3. Thanks for the additional information. It turned out that it was my Firewall. I had set it to stronger settings. When I returned it to "default" settings the problem went away.

    I use Intego VirusBarrier6 for Mac. Cheers!

  4. Thanks for the follow-up info. It's nice to have it posted together with the original question in case others run in to the same issue.

  5. I have the exact same problem .... Visual Editor is available when using "New Post" (postto.wordpress.com) from the blog page but not avail when in Admin pages.

    There is no "Visual" or "Text" tab and if I go to User Profile there is no selection to turn Visual Editor on or off appearing.

    Tried disabling anti-virus and no change. Cleared cache etc as well.

    Tried Chrome, Firefox and IE - all updated. That the Visual Editor works in one place indicates the Flash/java etc would seem to be correct.

    That the option to select Visual or Text is missing altogether is confusing.

  6. After much more digging setting to use https fixed it. Once that change was made the Visual and Text tabs appeared in Edit mode within Admin.

    That seems quite silly. That the New Post function would display Visual properly, but the Admin page would only show the Text Editor unless using HTTPS makes little sense. It should be same for both.

  7. That seems quite silly. That the New Post function would display Visual properly, but the Admin page would only show the Text Editor unless using HTTPS makes little sense. It should be same for both.

    It's not something being caused by the WordPress.com site, it's something in your firewall or network settings that's blocking a part of WordPress.com from loading the scripts it needs to run. It's usually a pretty rare issue, running in HTTPS mode is one workaround because it's bypassing whatever local network scanner or firewall rule that was blocking you before.

Topic Closed

This topic has been closed to new replies.

About this Topic