Need help? Check out our Support site, then


Visual Editor not displaying DIV in correct location

  1. Hi,

    New to all this so please excuse my ignorance.

    Using WordPress, Catalyst and the Ultimate TinyMCE plugin, I am using the layer button to add a DIV to my page. Using the Visual Editor, I can move this DIV around the page to where I want it but when I publish, the DIV shows up a different location to where it's supposed to be.

    My site, which is provided by a hosting provider, is essentially made up of a header and footer over which I have little control (other than the contents of menus and widget areas). But I can edit the main body of each page that I create and this is what the Visual Editor gives me control over.

    This page illustrates nicely my problem:

    http://lynbrook.org.au/secret2-2/

    This is the contents of the HTML for this page:

    [code]
    <p>
    <img class="size-full wp-image-2950 aligncenter" title="Radio Microphone" src="http://lynbrook.org.au/wp-content/uploads/2013/01/Radio-Microphone.png"
    alt="" width="97" height="150" />
    </p>
    <div style="position: absolute; left: 317px; top: 167px; width: 206px; height: 123px; text-align: center;">
    <span style="background-color: #adff2f;">
    This is my DIV that I created with the layer botton. I have placed this on the page in the Visual Editor so that it appears
    to be centered directly beneath the microphone image on this page.
    </span>
    </div>
    [/code]

    Although I have a reasonable understanding of basic HTML, I'm not overly familiar with WordPress itself. Any help would be greatly appreciated.

    The blog I need help with is cdmonline.wordpress.com.

  2. If you're self-hosted, then you need to ask on this forum instead:

    http://wordpress.org/support/

Topic Closed

This topic has been closed to new replies.

About this Topic