Need help? Check out our Support site, then


website title on google search

  1. Hiya

    When putting my blog URL directly into google search, it shows the title of the website as my real first name and then the link, like this:

    Fuad - 4:18pm
    lordgenome.wordpress.com/

    I've blocked search engines for my blog, and i don't really mind my blog coming up when the URL is directly searched for, but how would i remove or change my name from the header/title? i was unable to find the option to change this feature, or able to find any support for it whilst searching the forums (probably due to the lack of specific keywords, maybe). any help would be greatly appreciated.

    The blog I need help with is lordgenome.wordpress.com.

  2. Two options are available to you.
    1. Switch to a theme that does not display authors. > http://wpbtips.wordpress.com/2009/08/15/author-displayed-or-not/
    2. Change your display name to a nickname on your Profile. >
    http://en.support.wordpress.com/change-your-username/#change-display-name-nickname

Topic Closed

This topic has been closed to new replies.

About this Topic