Need help? Check out our Support site, then


What just changed with adding media?

  1. Up until a few days ago, inserting a mp3 media file produced the following html:

    One Way Ticket

    a few days ago, something changed, and now inserting a mp3 media file produces the following html:

    [audio http://toolsforhope.files.wordpress.com/2013/03/jam-april-15.mp3%5D

    What changed, and more importantly, what do I do to get back to the prior code generated?

    The blog I need help with is toolsforhope.com.

  2. Faith Bible Church

    I'm having the same problem. When I try to upload my media file, it goes to my media library okay, but when I try to insert it into a post, it comes up with a media player. I don't want it that way. I want it just to be a link to the media file. I made sure I had checked the link to media file button. Please advise.

    My blog is http://www.faithbiblechurchofwarren.wordpress.com

    Any help would be appreciated.

  3. alisonearlsaloud
    Member

    I'm having exactly the same problem. The 'Media File' option is now inserting the media player (the same as 'Attachment Page' or 'None') so there is no way of inserting a LINK to a media file for visitors to download rather than play immediately. M

    My blog is http://alisonearlsaloud.wordpress.com

    Thanks!

  4. Try this: switch the editor to Text, highlight the mp3 URL, click the code tool.

  5. alisonearlsaloud
    Member

    Thanks for the suggestion. I just tried that but it didn't work ... the media player still appears. The suggestion I found from macmanx to another forum post about this problem is an OK band-aid i.e.

    For now, you can get the file's URL from the Media library, then insert it like a normal link into the post or page.

    However, when someone goes to download the linked file it will be named with the full link (or shortlink if you've used that option) instead of the name of the media file itself. So hopefully the 'Insert Media' options will be fixed soon!

  6. Thanks for the suggestion - but I tried it and it didn't work - media player still appears, as opposed to a link as before. If this was a change by WordPress, then please give us the OPTION of inserting the link (as it was until a few days ago). I put out a mp3 link every weekday, and now have to perform extra editing in order to get what I had before. Thanks

  7. alisonearlsaloud
    Member

    I'm with you, bobsemp ... I need the option to add a link that will allow visitors to download an mp3 file that's correctly named.
    But until this is rectified, at least the option of going to the Media Library and getting the link/shortlink to insert onto the name (text we type manually) allows visitors to download the file in the interim. It's just a valuable resource to avoid any confusion by allowing the file to be downloaded as name.mp3 instead of a lengthly link or meaningless shortlink.

  8. Sorry for the wrong suggestion: it works with video URLs, so I mistakenly assumed it would work with audio URLs too. Thanks for posting the right workaround.

  9. alisonearlsaloud
    Member

    No problem! Any suggestion is worth trying so thanks for putting it out there. (plus if it works with video, it's a logical assumption it would work with audio ... aaah, logic ... not always in factor in technology, I've discovered.)

  10. Guess I should be specific ... I can get back to what I want on the page making text changes to the html, I just want to know WHAT/IF/WHY WordPress decided to make a change that now requires me to make changes to the html (where I didn't have to before) when adding media to the page from my media library. IMHO, they should have at least retained a sticky option, rather than just changing things and making it more difficult.

  11. alisonearlsaloud
    Member

    I think it's just a error that will hopefully be rectified. In the other forum post, macmanx said:

    Sorry for the trouble, we're looking into this!

    so that indicates that it's something unintentional that they might restore to 'normal operations' now that they know it's an issue.

  12. After posting in this forum and not getting any quick help, I posted in the support forum. Here is the answer I got and it is helpful. I do hope they find and fix the problem soon, as it was so much easier.
    ----------------

    I've confirmed the problem and it's been reported to our development team. It looks like the shortcode for creating a player is being inserted when you want just the link.
    For now you can manually fix it by removing the extra code and changing the path to a link. For example, you might see a code like this appear in the text box:

    [audio http://yourblog.files.wordpress.com/2013/04/song-12-04-20131.mp3%5D

    You should remove the brackets and the word audio so that only the direct file path remains:

    http://yourblog.files.wordpress.com/2013/04/song-12-04-20131.mp3

    Then highlight and copy that file path, and turn it into a working link by clicking the link icon and pasting in the file path.

    I hope that helps -- let me know if you get stuck.

  13. Thanks bonlou (et al) ... guess I'll just wait for the support team to "fix" the bug ;-)

  14. alisonearlsaloud
    Member

    Thanks bonlou! I posted the Support question "Will the Insert Media option where a link to a media file is displayed be restored?" and macmanx has replied:

    We're looking into the issue, but for now, you can get the file's URL from the Media section of your blog's Dashboard and insert it like a normal link: http://en.support.wordpress.com/links/

    but I like the removing the extra code fix better ... saves tracking down the link in the Media Library.
    Good to know that a return to the previous method we were all used to is on the way.

Topic Closed

This topic has been closed to new replies.

About this Topic