Need help? Check out our Support site, then


When should I update my mac snow leopard for safari and firefox updates?

  1. In my settings page, it says I need to update safari. However, I have mac snow leopard, and safari won't update on it.
    Everything works well, and I don't want to change my operating system until I really have to. I shall get some advice about this at the Mac genius-bar on thursday - they told me wp is using more flash adobe etc which needs Lion.
    But I would much appreciate some inside info about this.
    How long can I continue blogging on Snow leopard?
    Thank you

    The blog I need help with is janeadamsart.wordpress.com.

  2. ADDITIONALLY -
    Is there meant to be snow/white dots on my stats and settings pages? Just noticed it today. Can I get rid of it? Thanks again!

  3. ADDITIONALLY -
    Is there meant to be snow/white dots on my stats and settings pages? Just noticed it today. Can I get rid of it? Thanks again!

  4. Disable the snow here > https://wordpress.com/#!/settings/
    After you disable you will want to clear your browser cache so your aren't viewing a cached copy > http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=32050

  5. How long can I continue blogging on Snow leopard?

    I don't have an answer and have tagged this thread for a Staff response.

  6. Should I clear cookies before or after disabling snow? I have never done so before, as I didn't understand well enough what they are. Your google link says an error is detected with my cookie settings. Shall I just go ahead and clear them - will it show what the cookies are?
    Thank you

  7. After.

  8. Does the error (google link) simply mean the cookies need to be cleared now? Sorry - am a bit nervous! I have found where to disable snow, thanks for your help.

  9. Hello Timethief. I see how to delete cookies. Do you recommend I delete them all, or keep a few which are related to my interests, after disabling the silly snow?
    Thanks - Jane

  10. As long as you're using one of the many browsers which is compatible with WordPress, your operating system doesn't matter.

    they told me wp is using more flash adobe etc which needs Lion.

    That is incorrect. You certainly don't need Lion to run WordPress. In fact, I'm using Snow Leopard right now. :-)

    You don't need to worry.

  11. Thank you Kathryn! eased my mind, because I don't like to change things when they are working well. At apple also, they said that snow leopard has a large user base and will continue for a good while. It must have been some geek who told me otherwise, on the phone.

  12. Great! Happy blogging. :-)

Topic Closed

This topic has been closed to new replies.

About this Topic