Need help? Check out our Support site, then


When trying to connect to Facebook on Share settings, page goes blank then close

  1. I'm trying to connect my facebook profile to my blog (on Share settings), It asks me to log in to facebook, after logging in it displays a blank (white, nothing) page. If I try to reload the page it automatically closes the browser/tab

    The blog I need help with is theuniqueday.wordpress.com.

  2. Is your Flash up to date? See here for confirming Flash is updated http://www.adobe.com/software/flash/about/ and if required installing the latest version of Flash http://www.adobe.com/products/flashplayer/

  3. thanks for the reply!
    Yup, flash is up to date.
    Tried it in two different browsers (chrome & Safari) and both are giving me the same error.

  4. I flagged this thread for Staff help.

  5. duncanmhamilton
    Member

    I've been having the same problem! Has a solution been found yet?

    thanks

  6. Please try the full reconnect procedure detailed at http://en.support.wordpress.com/publicize/#reconnecting-facebook

  7. duncanmhamilton
    Member

    Hi, thanks for the response. I've cleared the wordpress app from Facebook, which does appear in the apps on my page. Blog posts don't update there though even when it is listed, and there is no 'x' to uncheck on the wordpress sharing settings page when following the reconnect procedure.

    Every time I try to reconnect, I go the whole way through the process and when I click on the 'allow' button, the browser window goes white and nothing else happens, and if I try to refresh, the window closes as described above. I do not get any confirmation window.

    WordPress does appear as an app in my facebook settings, but my wordpress settings page does not show any connection to Facebook. Blog posts do not appear there when I publish them.

    Apologies if there is something obvious that I am missing, I'm still pretty new to wordpress! Thanks again!

  8. Ok, there may be something up with the browser then.

    First, make sure that your browser is up to date by visiting http://www.whatbrowser.org/

    If it is not, please try updating your browser or switching to a different browser.

    If it is, please do these four things:

    1. Try clearing your browser's cache and cookies: http://en.support.wordpress.com/browser-issues/

    2. Make sure that you have third-party cookies enabled: http://en.support.wordpress.com/third-party-cookies/

    3. Try with all browser extensions or add-ons temporarily disabled.

    4. Try enabling HTTPS: http://en.support.wordpress.com/https/

    Please let us know how each step goes for you, and which browser (and version of) you're using if you're still having trouble.

  9. duncanmhamilton
    Member

    Hi, thanks for the response.

    I've tried those steps, and it hasn't made any difference, the result is the same. I'm using Safari 6.

  10. Are you trying to connect to a Facebook Page-only account? If so, you'll need to give your Facebook profile Admin rights to the page.

    If you don't have a Facebook profile, you'll need to log out of the Page-only account and create one.

  11. duncanmhamilton
    Member

    Hi, yes it's a page only account. Right now I'm listed as the manager of the page. Do you mean that I have to set a separate private profile page on facebook, assign admin rights to that profile, and then go through the process of connected WP to FB again?

    thanks again!

  12. No, you just have to assign admin right to your own Facebook profile, the same profile that you're connecting with Publicize.

  13. duncanmhamilton
    Member

    I set up the FB page, and as best I can see I have all the rights available.

    WordPress is actually listed in the apps of the page in the settings > apps part, but when I post a blog here, there is no update on face book, and there is no indication on my WP dashboard settings > sharing that there is any facebook page associated with the blog, nor does there seem to be any way to interact with WP on the front page of the FB page.

    I'm afraid I'm not actually sure what it should look like when it is all up and running so I'm not really sure of what should actually be there.

  14. duncanmhamilton
    Member

    I should add that the WP app is present in the settings screen accessed from the top bar of the FB page, i think this is the account management part, distinct from the page management part.

    When I click on the page management settings, and the apps option there, that lists photos, events, notes etc, there is no sign of the WP app.

    Thanks again for the help!

  15. there is no indication on my WP dashboard settings > sharing that there is any facebook page associated with the blog

    At Settings -> Sharing, look near the top at the Facebook section. You should see a page name there above "Add a new Facebook connection." Or, do you only see "Add a new Facebook connection"?

    nor does there seem to be any way to interact with WP on the front page of the FB page.

    You'll never see anything like that on your Facebook page. Publicize simply automatically shares new posts to as links on your Facebook page.

  16. duncanmhamilton
    Member

    No, there's just the 'Add new facebook connection' button. The next thing above it is 'more info on using publicize' link.

    When I tried to connect it, I never got any confirmation, it was at this point that I got the blank window.

  17. Would you please take a screenshot of your Facebook page when you're logged in, and upload it via Media -> Add New in your blog's Dashboard?

    This will allow us to confirm the status of the page.

    http://en.support.wordpress.com/make-a-screenshot/

  18. Hi Macmanx, tried the reconnection procedure you suggested; deleted the wordpress app from facebook, then when trying to reconnect I get an error message on the publicize dashboard: "There was a problem connecting to Facebook to create an authorized connection. Please try again in a moment." However, I've been trying this since Thursday and it keeps popping up the same error. any ideas how I can fix that?

    Thanks again for the replies

  19. I forgot to add, I also am trying to connect a page-only facebook account to WP. Does this mean I need to give my personal FB page admin rights to the page-only account on FB and then try reconnecting?

  20. Yes, the same applies to you. If you're trying to connect to a Facebook Page-only account, your personal account needs to have admin rights to it.

  21. duncanmhamilton
    Member

    Hi,
    just wanted to thank you again for the help, I'm up and running now. The issue was that when I signed up for facebook, it was only for a page account. I didn't have a personal profile which I needed to create and then connect to the page.

    I followed the instructions here to sort it out:
    http://en.support.wordpress.com/publicize/#facebook-page-only-accounts

  22. You're welcome!

  23. ^ linking the page account to my personal account as a manager solved the issue, thanks so much!

Topic Closed

This topic has been closed to new replies.

About this Topic