Need help? Check out our Support site, then


Where can I report a bug? Some of my animated gifs display as still images

  1. Hello,
    I have a problem that started not so long ago. Maybe a couple of weeks ago. The problem is that all of my animated gifs work properly on the page where I edit the post but as soon as I save the progress and view the post on the blog, some of the animated gifs display as still images. Even right-clicking and choosing the option "show image" doesn't work - it shows the same still frame of the animation.
    I've tried to delete and upload an image from my gallery again, but to no avail. I'm not sure but it's possible I've also tried uploading it again from my hard drive with the same result.

    Some of the gifs stop working on one occasion but then work properly. The problem is that some never worked again. It may be a coincidence but it may be that smaller gifs are less likely to become still images.

    I wonder... I usually remove the ugly interrupted line from under the images which indicate that there's a link to the image. It hasn't been a problem up until now but maybe it has something to do with the problem?

    My two last posts have this problem and it's getting really frustrating.

    Thanks in advance for any help.

    The blog I need help with is lifessavepoints.wordpress.com.

  2. a) Animated GIFs must be inserted in real size: they lose the animation when downsized.
    b) You've got too many images and other inserted objects on your main page: if you don't have a fast connection, or if you have a temporary connection problem, the browser may not be able to display them all correctly. You need to decrease the number of posts per page in Settings > Reading, and/or use the read-more tag to truncate the posts.

  3. First off with so many images, and because animated gifs can get huge, go to
    settings > reading in your dashboard and set your site to shop perhaps 2 posts per page and see if that helps. After 5 minutes my system was still downloading from your site.

  4. @Panos, G'day to you!!

    I should have refreshed.

  5. ~~

  6. Thanks.
    I'll try to do what you suggested, although I'm intimidated by the thought that I'd have to upload all the gifs once again in their original size (the only reason why I began downsizing them is because the caption borders became distorted in one of the earlier posts).

    While I understand why too many long, image-laden posts on a blog page can slow it down, I don't see why it doesn't work when I view only the page with the post I worked on.

    And I don't get why all worked well so far and just recently decided to go bonkers. I resized animations earlier and never had this problem.

  7. Perhaps there's some confusion here: I'm talking about images downsized in the post after you have uploaded them. The only such case on your main page is the image "pornografia-sztuka" (uploaded file 500px wide, inserted version 360px). All the other GIFs on your main page are working (because they have been inserted in real size), except the image "animacja-zycie-komputer-czekanie-klepsydra-nieskonczonosc-zmiany" which is probably defective or I don't know what.

  8. @Justpi.
    I uploaded some animated gifs once more in their original size. They work fine now. I tried to resize them in Irfanview and then upload them without losing the animation but I have to stop the animation because I can't edit its size when its running. But when I do, I can't turn it back on and when I try to save it, it saves as a still frame. Oh well...

    I didn't know the animacja-zycie... gif wasn't working. It was supposed to be an animation of an hourglass spinning endlessly. But I might have resized that one too. I'll check that out.

    Thanks for your help.
    And thanks to all others who replied or took interest in this thread.
    I'm glad I don't have to wait for the staff to fix a technical problem.

  9. There are several gif resizing sites online that are free to use. Try some of them.

Topic Closed

This topic has been closed to new replies.

About this Topic