Need help? Check out our Support site, then


White space under the sidebar?

  1. Well, If you look at my blog, There's this white space under all the widget's on the sidebar. I want to make it so it's a different color. Does anyone know how to fix it?

  2. forgotten something?

  3. Oh, And guys my blog is http://www.cheatgnome.org/

  4. If you view some other blogs with the same theme as me.

  5. http://validator.w3.org/check?uri=http%3A%2F%2Fcheatgnome.org%2F&charset=(detect+automatically)&doctype=Inline&group=0
    I am guessing it is the unexplained </li> </ul>
    but with 95 html errors, it is hard to tell.

  6. hmm, Well thanks for You're help. I'll keep searching.

  7. Does anyone know how to fix this? I know it's on the css, But witch thing do I change on the css?

  8. I don't see a white background under the widgets.
    By adding background: yourcolor; to #menu you can assign a color.

  9. Actually in your CSS, add it here:

    `#menu ul, #menu ul ul {
    list-style-type:none;
    }

  10. I just tried it, That Don't work.

  11. Can anyone help?

  12. thesacredpath
    Staff

    If I add background: red; to the section in your CSS that I posted above, it changes the color of the background for the widgets. Replace red with whatever color or hex code you want.

  13. thesacredpath
    Staff

    Actually, there are two areas that will put color behind the widgets.

    #menu {
    background: red;
    }

    That actually extends the new color over a little farther to the left.

  14. I tried it, That doesn't seem to do anything.

  15. thesacredpath
    Staff

    I can go to your site and temporarily change it in your CSS using Firebug, and it works for me - both of them.

  16. hmm... So under the sidebar there's no white?

  17. Guys, On you're computer look under my sidebar, There's should be a small white space. does anyone know how to fix it?

  18. thesacredpath
    Staff

    Under #menu you have defined a bottom 30px solid white border. Remove this and the bottom white border goes away:

    border-bottom:30px solid #FFFFFF;

  19. That didn't work. hmm,

  20. Well, I guess I'll ask someone who's blogged a while.

  21. thesacredpath
    Staff

    OK, try changing it to border-bottom: none;

  22. Ok.

  23. Thank you!, That worked. Thanks dude you rock! And thanks to everyone else who tried to help me.

  24. thesacredpath
    Staff

    You're welcome. I'm not sure why removing the border-bottom didn't work for you. It did when I was using Firebug, but setting it to none does the same thing.

  25. Obviously I can't see the problem now, but if the problem was just in Internet Explorer, then its a common problem and an easy fix. You can fix it with simply putting overflow:hidden; in the css code for the div where the problem is.

  26. Actually it showed up in Firefox and Safari as well. It was the "border-bottom" that was causing the issue.

  27. Moved topic to CSS Customizaton forum.

Topic Closed

This topic has been closed to new replies.

About this Topic