Need help? Check out our Support site, then


Why are my comments inexplicably "off"?

  1. My comments are inexplicably off.

    The blog I need help with is makeaneffort.wordpress.com.

  2. I just left a comment without any problem here http://makeaneffort.wordpress.com/2013/12/06/got-mad-skillz/#comment-2621 Are you referring to another blog? If so what is the URL please?

  3. It's only on new posts.

    if you scroll down the blog you will see some comments as "off". I never disable comments. But it seems to be happening on everything new created.

  4. Hello there,
    Please confirm that your settings are correctly set. All WordPress blogs by default have comments open on all Pages and Posts. You can enable and disable comments on free hosted WordPress.com blogs on this page > Settings > Discussion

    Discussion settings is where you set up defaults for comments.
    http://en.support.wordpress.com/settings/discussion-settings/

    You can override the default settings and enable or disable future comments on any individual post or page.
    http://en.support.wordpress.com/enable-disable-comments/

    Note: By default, new blogs on WordPress.com will have the Discussion hidden. You can reveal it by clicking on Screen Options http://en.support.wordpress.com/screen-options/ on the top right corner of your Admin page, and checking the box that says Discussion so the module is included. http://en.support.wordpress.com/modules/#list-of-modules

  5. Understood. I have done this. I've also been using WordPress at this location for almost two years... not sure if that would make me "new". May be it does.

    This just started over the last few days.

  6. i have tagged this thread for Staff assistance. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.

  7. thank you! I appreciate it.

  8. You're welcome.

  9. We've had a couple reports of this but so far can't pinpoint a cause or reproduce it on our end. Could you please keep an eye on this behavior and see if it continues or if it's resolved after your next post?

  10. @happyburnscar, a question: when you created the post that had comments turned off, were you in the post editor window itself or using the post option from the WordPress.com home page? And were you on a desktop/laptop browser or on a mobile device?

    @timethief, we're looking into it.

  11. I created both posts on which this occurred in the "quick post" window on the dashboard. Typically I will start them there then edit them in the post editor. I post from a desktop... because my fingers are super fat and I like ye olde timey feel of the giant soviet style keyboard.
    Hope that helps! I'll send you pictures of my ridiculous fingers... could be the problem.

  12. @happyburnscar, I'm still unable to reproduce this behavior. Can you try logging into WordPress.com in a different browser to see if that changes the comments functionality?

    Also, if you are editing in the post editor, you can double-check to make sure your comments are turned on by scrolling down to the individual post discussion settings, which should look like this for comments (pingbacks aren't important here): https://i.cloudup.com/48g3vWQAjT.png

  13. I also run explorer on my laptop... but I haven't been able to log into wordpress on the laptop since I bought it. I think it has something to do with windows 8. So I don't bother trying anymore.

    may be if we look at a specific problem?

    Could you access my account and turn "on" the comments for the post "Minority Rights".

    I still can't figure that out. The discussion box is checked now... I couldn't get it to remain checked before... but the post still shows comments as "off".

    I'll post something new today and see if it occurs again. Might just be an anomaly.

    I genuinely appreciate your attention on this. You guys have been very helpful even though we can't seem to figure out what's up.

  14. I'm still looking into this issue for you.

    I just clicked on "Allow Comments" and updated the post, and the selection is still there for me. Could you check to see if it shows up for you? (Note: you have to save a post draft or update a published post for any changes on that screen to be saved).

  15. Ah-Ha!

    I now see a bar in post editor with a box to check in order to allow comments. It allows me to enable comments for each post. While I've never had to do this in the past as it seemed to default to allowing comments I know to check the box each time.

    Thank you, thank you, thank you!

  16. For now, it's a good idea to check the box each time you have a new post. Hopefully this workaround is just temporary, since we're still trying to figure out why comments are not on automatically for some users.

Topic Closed

This topic has been closed to new replies.

About this Topic