Need help? Check out our Support site, then


Why are there two versions of my post?

  1. empoweredintuition
    Member

    Hi,
    Just to contextualize my situation first, I would like to mention that my blog's front page is a static page called "About", which means that all my posts should go under the menu called "Blog" (as I have set it up). I just published a post and it looks the way I want in the preview since it has the option of likes and shares. The problem is once I click on the menu "Blog", the same post appears, but does not have the option of likes and shares. Why is that?

    The blog I need help with is amandanguyenfilmdiary.wordpress.com.

  2. Change your sharing settings to show icons also on the front page, archives, and search results. See here: http://en.support.wordpress.com/sharing/#customizing-sharing-settings

  3. Just to clarify, there actually aren't 2 versions of your post.

    The post appears on the home page of your site, as well as on its own page, called single post view. To make this clearer for Bushwick the theme you are using, see the demo site here: http://bushwickdemo.wordpress.com/

    Currently you have your sharing settings to only show icons on the single post view.

  4. The difference isn't clear to you yet because you've published only one post.

    When you click Preview while editing a post, you view a single complete post. When you view your "Blog" page, you view an archive page.
    The two views aren't the same: the single post view displays the entire content of the post plus its comments section; an archive view displays a series of posts (in reverse chronological order), it doesn't display the comment section of each post, and it can display excerpts instead of full posts.
    Blog page:
    http://amandanguyenfilmdiary.wordpress.com/blog-3/
    Single post:
    http://amandanguyenfilmdiary.wordpress.com/2014/01/25/abstract-4/

    When you're on an archive page, you move to a single post by clicking the title of the post, or its comment link, or (if the page displays excerpts) its "Continue Reading" button.

    Displaying Likes and Shares is optional. Enabling them on the single post view and enabling them on archive pages is two separate options (set in Settings > Sharing).

    If you prefer full posts on your Blog page, follow Jennifer's suggestion.
    If you prefer excerpts on your Blog page, don't change the settings; instead, edit the post and insert the more tag to truncate the post, so that visitors will have to click "Continue Reading" to see the entire post (including its Likes and Shares).
    http://en.support.wordpress.com/splitting-content/more-tag/

  5. @justpi- by default Bushwick only displays the most recent post in full. All the other posts are only the post title, so one is forced to click through to the single post view. :) Come to look again, the Archives, Categories, etc. and Search results are only post titles, so it's only the newest post that is involved here.

    Personally I don't think the demo site for Bushwick really shows the theme to its best advantage.

  6. empoweredintuition
    Member

    Hi all,
    Thank you very much for helping me. It finally works now that I went in Settings > Sharing and enabled the option. It is true that the theme Bushwick is quite complicated to use, so I am considering to change it.
    Once again, thank you.

  7. @Jen: Right - thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags