Need help? Check out our Support site, then


why do all the pages I publish have the content of my front page?

  1. I created a new page with a link to a document. In the edit screen, it shows the page (called SOV how-to), and the content. On the blog itself, when you click on the SOV page, it shows the page I've designated as the front page (called welcome to the tspm online). I can't seem to get it to update the SOV page with the SOV info. The blog is mtnapus.wordpress.com.
    Thank you,

    Jasmine
    Blog url: http://mtnapus.wordpress.com/

  2. Pages are static and are for content that rarely changes. They sit outside of the blog structure and you cannot post to multiple pages in any blog. There is only one main page for posts in a blog and all posts will display on the main blog page. There is no way to exclude posts from the main posts (blog) page.

    The front page of the blog by default will display your posts (not pages) in reverse chronological order, with the most recently published post on top. If you do not want all the posts to show on the front page, then you can create a static front page http://en.support.wordpress.com/pages/front-page/

    Though there is only one dynamic page in a blog for posts and we cannot post to more than that one page, we can create the appearance that we have posted to more than one page. We organize posts by assigning categories to them. You can either put the categories widget into the sidebar, or you can create a custom menu and add the categories into the custom menu.
    http://en.support.wordpress.com/posts/categories/
    http://en.support.wordpress.com/widgets/categories-widget/
    http://en.support.wordpress.com/menus/
    http://en.support.wordpress.com/menus/#adding-category-pages-to-your-menu

    Here’s a link to a custom menu walkthrough > http://onecoolsitebloggingtips.com/2011/08/11/wordpress-com-custom-menu-walk-through/

    There are many common errors, misunderstanding and misconceptions when creating custom menus and you can read about them here > http://wpbtips.wordpress.com/2011/12/19/custom-menus/

  3. Okay. I made (tried to make) a new menu, called reference documents, with the sov how-to page as a sub-heading. Now there are no pages showing along the top of the blog, except for the sov how-to, and when you click on that, you get the contents of a different page.

    I don't think my issue is that I don't understand the difference between a page and a post. I do. I want this to be a page, with just this one document on it, available all the time to my readers. The problem seems to be with creating the page.

    Thanks for your help, Time Thief. This certainly is one... :-)

  4. Look here please > Dashboard > Pages > All Pages
    Are the pages there?
    Check the page visibility settings if they are there http://en.support.wordpress.com/pages/page-visibility/

    Troubleshooting – My Pages aren’t appearing
    They must be public pages – not private.
    Public – The page will be visible to everyone.
    Protected – The page is protected with a password you set. Only people who have the password can view a protected page.
    Private – Pages are only visible to blog Editors and Administrators. Private pages are not visible in Reader, feeds, or in any search. A page can be private without being password protected.

    Troubleshooting – My menu isn’t appearing
    Go to the custom menu page in the dashboard Appearance > Menus and in the “theme location” module at upper left select your custom menu from the pulldown and then click “save”.
    http://en.support.wordpress.com/menus/
    http://en.support.wordpress.com/menus/#adding-category-pages

  5. yes, the pages appear in the dashboard. Yes, they are public.

  6. Got it: in the settings menu, I selected the page to use as the static front page, but didn't select anything under "posts page". When I select my "about me" page to be my posts page, all the other pages became visible.

    Thanks fo ryour help!

Topic Closed

This topic has been closed to new replies.

About this Topic