Need help? Check out our Support site, then


Why do my images disappear when I hit 'save draft'?

  1. aplaceforwriters
    Member

    My images, some of which I've used before - one in nearly every post I've done in 2.5 years - won't stay on the page. As soon as I hit 'save draft,' they disappear.
    Blog url: http://aplaceforwriters.wordpress.com/

  2. I am using Firefox 15.0.1 and I can see images. I see three images in this post > http://aplaceforwriters.wordpress.com/2012/09/13/apw-diy-interview-john-lavan/

    Please try clearing your browser cache and cookies > http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=32050

  3. aplaceforwriters
    Member

    You're looking at today's post ...
    I built that post a couple of weeks ago.
    It's the post I'm working on right now - the pictures do not stay in the 'edit page' screen. I haven't published this post yet, so you can't be seeing it.

  4. I flagged this thread for Staff assistance. Please be patient while waiting.

  5. Are you using the "Add New" on the main page for wordpress.com here http://wordpress.com/#!/post/ I'm asking as that link is only for creating "Asides".
    Aside – These are brief snippets of text that aren’t quite whole blog posts. Useful for quick thoughts and anecdotes http://en.support.wordpress.com/posts/post-formats/

    Or are you creating posts on your own blog's washboard here?
    http://aplaceforwriters.wordpress.com/wp-admin/post-new.php

    Do these troublshooting tips help? http://en.support.wordpress.com/images/troubleshooting-images/

  6. washboard = dashboard lol :D

  7. aplaceforwriters
    Member

    Thanks.
    Fortunately, this post isn't to go live for a few days so it's not a panic situation.

  8. Let's hope it all irons out in "the wash". lol :)

  9. aplaceforwriters
    Member

    I created this post the same way I've created posts for 2.5 years, by clicking on the 'Add Post' tab on the left side of the screen, right underneath the 'All Posts.' I didn't know there was any other way to do it.

    I don't know what a 'washboard' is, so it's pretty safe to assume I'm not doing whatever that does.

  10. aplaceforwriters
    Member

    Yes, I'm using my dashboard. Again, I didn't know there was any other way to do anything except via the 'washboard.' LOL

  11. Thanks for the additional information.

    I was making fun of myself as when I first typed above I typed "washboard" instead of typing "dashboard". I'm sorry for the levity. Staff will deal with your issue when they can.

  12. aplaceforwriters
    Member

    LOL
    I've had some strange stuff happen, but never disappearing pictures.

  13. Off-Topic:
    My husband has some pictures of me on his site I would like to disappear but they never do.

  14. aplaceforwriters
    Member

    Now, don't apologize ... There are OODLES of terms out there I've never heard before. I just assumed that was one of them. Nothing to apologize for. LOL

  15. aplaceforwriters
    Member

    O-o-o-o-h ... and WP doesn't have a 'Content Warning' page like Blogger does. LOL

  16. aplaceforwriters
    Member

    Hi,
    It's now the 17th and I really need to do this post!!
    It's important that I am able to do pictures as this is the LAST POST I'll do on this site and I need to get people's attention. (I've got a new WP.org site up and running starting next Monday.)
    As before, I can place the pics on the Edit screen, but as soon as I click on 'Save Draft,' the pictures disappear!
    Thank you!
    Julie

  17. I wonder if either of these methods might get you through:

    Schedule your post. And see if that saves your images.
    http://en.support.wordpress.com/posts/schedule-a-post/ you can later go in and set it to publish immediately whenever you are ready to publish.

    Or publish the post as private until you are ready to release. That way you can see if the photos appear, but others can't see the post. I have seen other posts on disappearing pictures using the save draft, and seem to recall this as one of the options listed.

    Good luck with your .org site.

  18. aplaceforwriters
    Member

    I schedule automatically when I start a new post, so it's already scheduled.

    I published it to private. NO CHANGE.

    I saved the copy and sent the post to trash, then opened a new post. NO CHANGE.

    THIS post, of every one I've ever done, is very important - telling my readers the URL of my new site ---- I REALLY NEED TO BE ABLE TO USE PICTURES TO GET PEOPLE'S ATTENTION! It's been almost a week now and this post will go live at midnight Thursday morning. PLEASE!!!

  19. @aplaceforwriters — Are you referring to your draft post scheduled for 9/20?

    If so, are you viewing the Visual editor on the Edit Post screen? I'm able to see the "Blog" callout image there.

  20. aplaceforwriters
    Member

    Yes, it's the post that hasn't been published yet for 9/20.

    If you can see 1 'BOLG' thingy, then you should be seeing a dozen or so because I keep calling in another one when I try something and every time, when I click 'Save Draft,' it (and any other pic I try) goes away. As the screen refreshes, the pic is there for a second, but disappears.

    I have a choice between the 'plain English' screen and the 'gobble-d-guck' screen when I work on my posts. Since I'm not fluent in 'gobble-d-guck,' I use the 'plain English' screen.

    How is it you can see an unpublished screen with pics on it that I can't see?

  21. If you can see 1 'BOLG' thingy, then you should be seeing a dozen or so because I keep calling in another one when I try something and every time, when I click 'Save Draft,' it (and any other pic I try) goes away. As the screen refreshes, the pic is there for a second, but disappears.

    Can you try closing all the tabs in your browser, then quit and restart Firefox?

    How is it you can see an unpublished screen with pics on it that I can't see?

    I can only see one one image inserted.

  22. aplaceforwriters
    Member

    Well, since this problem cropped up on the 13th, I've shut down the computer for the night every night since then (and Firefox - and the tabs - all shut down when the rest of the computer shuts down). So, I've completely shut down at least 5 times since this cropped up.

    Some days, because of resources issues, I restart during the day, too, so I've completely shut down MORE than 5 times since this cropped up.

    I just checked, it's still dumping the pics when I hit 'Save Draft.'

  23. Okay. After you insert the images into the post with the Add Media button, can you switch to the Text editor, select all the text, copy and paste it into a text file? (Save that to your desktop for safe keeping, in case your changes aren't being saved.)

    Then, please take two screenshots and upload both to your Media Library:

    1. What you see in your browser window before you click Save Draft
    2. What you see after you click Save Draft

    Also, can you let me know if you get the same result as before in an alternate browser, such as Google Chrome?

  24. aplaceforwriters
    Member

    1) 'before' and 'after' are in my media library.

    2) I don't have another browser on board. Firefox has worked for over 2.5 years. Why would it suddenly become the problem? I have a WP.org site up and running now, and have loaded dozens of pics onto the site so it's not Firefox.

  25. aplaceforwriters
    Member

    This post isn't complete ... when I started having the problem, I stopped working on it.

  26. 'before' and 'after' are in my media library.

    Those screenshots are when previewing the post. Can you take the screenshots from your dashboard in the text editor?

    I don't have another browser on board. Firefox has worked for over 2.5 years. Why would it suddenly become the problem?

    I'm not sure, and that's what I aim to find out.

    For what it's worth, I was successful in saving a draft on my WordPress.com blog in Firefox 15.0.1 and the draft saved the post and the existing image inserted from my Media Library.

    You can download Google Chrome here:

    http://browsehappy.com/

    or here:

    https://www.google.com/chrome/

  27. aplaceforwriters
    Member

    The screen shots are from the text editor in the dashboard. I have 2 choices - plain English or gobble-d-guck. So, I use plain English. I don't know of any other way to do this. It's the way I've used it since starting this blog in late 2009. I don't even have the remote post creation stuff engaged - I use the dashboard - always have.

    I'm using the latest Firefox.

    If you saved the screen shot, of course you were able to 'save' the pics. They're all one piece. I use Snag-It for screen shots.

    Is it really necessary for me go gobble up a big pile of resources with another browser? What about the learning curve. I need this post to be complete and scheduled before bedtime tomorrow. With everything going on right now, I really don't have time to teach myself another browser right now. Since I have another WP running and working fine, it's a pretty safe bet it's not Firefox, esp. since it's the same version you're using.

  28. The screen shots are from the text editor in the dashboard.

    I'm seeing the before.jpg and after.jpg screenshots, but they aren't from the Text editor on the Edit Post screen.

    I've uploaded a screenshot to your Media Library that shows how the Edit Post screen looks. (I would've linked to it here, but I know you want to keep that announcement under wraps until Thursday.)

    In case it might have to do with an add-on or setting, can you try Firefox in Safe Mode?

    In the Firefox Help menu, click "Restart with Add-ons Disabled".

    Is it really necessary for me go gobble up a big pile of resources with another browser?

    To help us get to the bottom of this Firefox issue (post drafts not being saved) that I'm currently unable to reproduce, yes.

    Short of installing the browser and logging into your WordPress.com account at the top of http://wordpress.com/ , navigating to your WordPress.com blog dashboard is the same.

  29. aplaceforwriters
    Member

    OK, I'm not a techie. Firefox in the safe mode? Never heard of it.

    I haven't added any new add-ons in months so I doubt it's an add-on. Every time Firefox comes out with a new version I LOOSE add-ons!

    Doing the restart Firefox now - have to send this, or lose it.

    The text on the screen is being saved. I've had that same text on the screen since the beginning - I'm not rekeyboarding it every morning when I fire up. It's only the PICTURES that are disappearing!!!

    I'm in the screen you're saying I have to be in. I didn't know there was anyplace else I could be ... see the pic I put in the library. (It is big because I'm 64 and need things larger than the younger folks!)

  30. aplaceforwriters
    Member

    UM ... the pics are there ... so, it's an add-on, even though I haven't added any new ones in months. As I said, when Firefox goes to a new version, I LOOSE add-ons, so how can this happen?

Topic Closed

This topic has been closed to new replies.

About this Topic