Need help? Check out our Support site, then


Why does my uploaded YouTube video still appear on my blog page as a URL?

  1. I am trying to upload a video from YouTube to my web page. I have copied the YouTube URL across into the web page, made sure it is on a line on its own, and have made sure it is not hyperlinked. However, it still only appears as the URL, rather than the first frame of the YouTube video. I've uploaded a video before to the same site, but to a blog post rather than a page, and not had this problem, and can't see that I am doing anything differently. What is going wrong? Thanks

    The blog I need help with is helpinghearts2013.wordpress.com.

  2. Please post an active link starting with http:// to the post or page you embedded the youtube code into so we can examine it.

  3. Use the shortcode on a single line and change nothing I post. Don't add spaces and don't try to format it. Simply edit the post and copy and paste the shortcode on a single line and click "update".
    [youtube=http://www.youtube.com/watch?v=8B5Bd7g2_cI&feature=youtu.be]

  4. Hi. Thanks for your help
    This doesn't seem to be working - I've copied and pasted the shortcode (including the youtube=http:// bit, I assume) and updated the page, but it now doesn't appear at all - it doesn't even shoe the URL. And is also seems to format the first paragraph of text below, underlining it, which I can't undo.

  5. The entire shortcode above including the square brackets and everything in between is what you ought to copy and past.

  6. I just copied and pasted the shortcode I provided above into a draft post on my blog and it's working properly.
    Do not mess with the code. Edit the post. Then copy and paste this without changing anything at all and click update.
    [youtube=http://www.youtube.com/watch?v=8B5Bd7g2_cI&feature=youtu.be]

  7. Bizarre - I tried pasting it into a test blog post (rather than on to a page) which worked, then tried pasting it back into the web page. At first it didn't work, then it did! Thanks for all your help - seems to be ok now!

  8. Hooray! I love happy endings. Best wishes with your blog.

  9. Hey - happy ending is over... I'm trying to upload a second video and it's simply not working - the URL only appears, and when you publish it in shortcode format it simply doesn't appear. What crazy magic are you working?!
    Here's the new YouTube vid link:
    http://www.youtube.com/watch?v=SWuDzjU67xg&feature=youtu.be

Topic Closed

This topic has been closed to new replies.

About this Topic