Need help? Check out our Support site, then


why does the front page not show my posts?

  1. The front page does not display my posts. It says "nothing found" although I have already publicized two posts. Front page is set to show recent posts. And I have even ticked the box "stick to front oage" in my post settings. What's going wrong here?

    The blog I need help with is myworldiscolourful.wordpress.com.

  2. Are you clear on the differences between Posts and Pages?
    http://en.support.wordpress.com/post-vs-page/

  3. By default the front page of your blog displays all posts (not pages) in reverse chronological order, with the most recently published post on top. The 404 (page not found) error message on the front page of the blog appeared because the Admin of the blog deleted the placeholder Hello World post. http://en.support.wordpress.com/not-found/

    If you attempt to create a static front page and fail to create two pages ie. one for your static front page and one for posts to display on then you get the same result.

    If you do not want all the posts to show on the front page, then you can create a static front page called for example “Welcome” for your site and a “Blog” page for posts.

    To do that create two pages > http://en.support.wordpress.com/pages/ After you do that you go to > Settings > Reading and make the designation change and click “save changes”.
    http://en.support.wordpress.com/pages/front-page/

    Front page displays
    __ Your latest posts

    A static page (select below)
    Front page:
    Posts page:

  4. If you do want all the posts to show on the front page, then you go here > Settings > Reading and select
    Front page displays
    __ Your latest posts
    "save changes"

  5. Yup. I've done all that. the posts do exist as posts on the category pages. Just the front page won't show anything. Well, it does show the featured content photos. But not the posts. Not sure what else to do...

  6. What are the post URLs please?

  7. @katelava: The posts page on Untitled is supposed to showcase some sticky posts in the slider and display regular posts below the slider. Check the demo:
    http://untitleddemo.wordpress.com/
    You've published only two posts, and made them both sticky, so you've got no regular posts (yet).

  8. On Untitled, if you make posts sticky it keeps them off the front page! To display posts in the mini carousel for individual post views you need only select a featured image and tag them properly:

    Navigate to Settings → Reading.
    Scroll down to the section labeled “Featured Content”.
    Enter the name of a tag.

    The mini carousel is not actually a slider.

  9. Yes I got that now. Thank you all. Also, if they are featured, they will only show in the mini carousel/featured images section. Not as regular posts either. So the new post is just plain simple now and it worked.

  10. Leiden &
    Amsterdam, Holla
    nd

    You can make the title of that post break more gracefully. For some reason wp.com is set up so that there is not a single "orphan" word on a line (title) so it will cause odd hyphenation, cutting a word awkwardly. You can fix that like so:
    use the html entity & # 8201 ; (without the spaces) to replace the space before the word "Holland." The entity is call "thin space" and it will for a line break in a sensible way…

  11. sarahlynnpablo
    Member

    Thanks for asking this question, @katelava!

    So, there's not a way to have posts featured in the slider AND have them also show up below it? (Am just concerned about less web-savvy readers who may not know how to use the slider and think the content's not there.)

    Many thanks to all in this thread!

Topic Closed

This topic has been closed to new replies.

About this Topic