Need help? Check out our Support site, then


why doesn't the live preview for themes work properly for my blog?

  1. When I try the live preview feature for themes, only the black side bar loads. This started a couple of days ago. It doesn't matter which theme I try the live preview option on, I get the black bar (the features on the bar work fine). I have the 2012 theme, and want to update the look of my blog to reflect some changes in content and appearance.
    I never had this problem before.
    Help!
    Thanks in advance

    The blog I need help with is phylor.wordpress.com.

  2. Please post the URL of the blog your refer to as the one linked to your username is wearing Twenty Eleven and not Twenty Twelve.

    There have been issues with the theme customizer. However, you do not need to load the design tools unless you have the Custom Design upgrade, which it appears that you have not purchased. All of the very same functions can be accessed from your dashboard.
    Appearance > Header
    Appearance > Background
    Appearance > Theme Options (applicable only to some themes)
    Settings > Reading (set a static front page)
    Site Title and Tagline > Settings > General

    If you want to change themes on a free hosted WordPress.com blog you must be logged in under the exact same username that registered the blog and who is the Admin of the blog. Note that no content is ever lost when changing themes.

    Go to Dashboard > Appearance > Themes
    browse themes until you find one you like and click "activate"
    or type in the name of the theme you want to use and
    click the "activate" link when it appears

    After you change your theme all you need to do is go here Dashboard > Appearance > Widgets > Inactive Widgets and re-install them where you want them to appear. The widget contents and settings will be the same as they were prior to changing themes.

    If you do purchase the custom design upgrade http://en.support.wordpress.com/custom-design/ I suggest being sure you are using a browser and version of it found here http://browsehappy.com and enabling third party cookies and JavaScript.
    http://en.support.wordpress.com/third-party-cookies/
    http://www.google.com/adsense/support/bin/answer.py?answer=12654

  3. Thank for reporting to my question. All the inform was useful, but my specific problem remains unanswered.
    I want to be able to use the live preview as I had been able to do before (at least 2 years)
    I like the live preview; it gives me an over view of how my blog will look. I had narrowed down the new blog images, and wanted to do the live preview one more time before I choose.
    I have a wordpress.com for my blog and have not purchased the premium option.
    Thanks for your response.

  4. Thank for reporting to my question. All the inform was useful, but my specific problem remains unanswered.
    I want to be able to use the live preview as I had been able to do before (at least 2 years)
    I like the live preview; it gives me an over view of how my blog will look. I had narrowed down the new blog images, and wanted to do the live preview one more time before I choose.
    I have a wordpress.com for my blog and have not purchased the premium option.
    Thanks for your response.

  5. As I said above there have been issues with the theme customizer. Staff is aware of them and the issue I expect it will be corrected in the next upgrade. Also note that as I said above you do not need to load the design tools unless you have the Custom Design upgrade, which it appears that you have not purchased, as all of the very same functions can be accessed from your dashboard.

  6. I am using Firefox 21 and I can access the theme customizer if I wish to use it but I don't.

    If you are not running one of the browsers and versions listed at http://browsehappy.com/ please try upgrading or switching first.

    Note: If you are using an IE9 browser in compatibility mode that makes it render as IE7 and IE7 is not supported. To disable see > http://www.sevenforums.com/tutorials/1196-internet-explorer-compatibility-view-turn-off.html

    If you are running one of the browsers and versions listed at http://browsehappy.com please do these four things:

    1. Try clearing your browser’s cache: http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=32050

    2. Make sure that you have third-party cookies and JavaScript enabled: http://en.support.wordpress.com/third-party-cookies/
    http://www.google.com/adsense/support/bin/answer.py?answer=12654

    3. Try with all browser extensions or add-ons temporarily disabled.

    4. Try enabling HTTPS: http://en.support.wordpress.com/https/

    If it’s still happening, let us know exactly which browser (and version of it) you’re using by checking here if necessary http://www.whatbrowser.org/ and also post any error reports you get.

  7. Thanks again, but I still don't quite understand -- I'm not trying to customize or activate, and I'm not concerned about design tools, nor purchasing an upgrade -- I just want to get live preview for themes working again. I can't pick a new theme, if I can't see how my blog will look.
    I will try some of your suggestions but I'm not sure that these will get to the heart of the problem -- having more than just the black side bar of live preview appear.
    What I don't understand is why one part (the bar that also contacts the activate or cancel "button) of the live preview function works, but the preview of how my blog would look in that theme doesn't.
    Thanks again. I will let you know if any of this works.

  8. There have been issue with the theme customizer. As I said above Staff are aware of the issues and they most likely with be addressed in the next upgrade.

    You do not need to access the theme customizer at all to select a new theme Go here > Appearance > Themes, select a theme and click "activate"

    Then go to:
    Appearance > Header
    Appearance > Background
    Appearance > Theme Options (applicable only to some themes)
    Settings > Reading (set a static front page)
    Site Title and Tagline > Settings > General

  9. ... live preview ...
    http://en.support.wordpress.com/third-party-cookies/
    Hopefully you have done as I said above and enabled third party cookies and JavaScript on your browser.

Topic Closed

This topic has been closed to new replies.

About this Topic