Need help? Check out our Support site, then


why don't my links show up ?

  1. thenaturalkitchen
    Member

    hey everyone

    happy new year! i just started my first blog a few days ago. i know some stuff about computers and making websites - but not very much.

    anyway - i followed wordpress.com's directions for how to make links from the Links FAQ's, i made two links on the static front page. one for the farmers market and one for the organic foods coop. i've tried them two different ways and no matter what, they are not showing up on my page when i view the site.

    i've tried them as "www.bla bla bla.org/" and as "www/bla bla bla.org" - no luck.

    can someone else look at it and tell me if they can see the links?

    my site is http://www.thenaturalkitchen.wordpress.com

    thanks! ~ susan

  2. Susan, Just for reference, none of the blogs here at wordpress.com have www in them. Some browsers will not resolve the link correctly if you include the www.

    If you are using the visual editor, highlight the text that you want to be a link and click on the "link" icon in the toolbar (looks like linked chain links). In the "link URL" filed, put the full url of the website you want to link to (example: http://www.farmersmarket.org). Make sure you have the correct URL. Then click the insert button and it will turn that text into a link.

    If you are doing it in the code view, the html will look like this:

    <a href="put full link here">put text here</a>
    The full URL will go between the quote marks, and the text you want to use will replace the "put text here".

  3. thenaturalkitchen
    Member

    hi sacredpath

    thanks for your quick response!

    i do think i did exactly what you outlined:

    the " http:// " part is automatically displayed in the field when you click the "chain link" icon

    and then i cut & pasted the " http://www.farmersmarket.org" part from the website link in the browser address window.

    so the address in my link window is http://www.bla bla bla.org

    so what's the missing link, so to speak? can you see any link on my static front page? they are both toward the bottom of the page - in the paragraph that starts "did i mention...."

    thanks again!

  4. thenaturalkitchen
    Member

    ooops - in the first post i meant that i tried these two variations:

    www. bla bla bla.org and www. bla bla bla .org/ (no spaces in either one)

    thx :)

  5. Without being able to see it, I don't know exactly. This is what it should look like in code view (assuming the text you wanted to use was "Farmer's Market").

    <a href="http://www.farmersmarket.org">Farmer's Market</a>

  6. Post the actual link you want to use here.

  7. thenaturalkitchen
    Member

    hey there sacredpath - and whoa...

    unfortunately - the HTML is more than my eyes/brain can comprehend...

    but my cut & paste from the websites in question were clean and the final result in the "create link" window on my "edit post page" is just as i show below (not a real website address but you get the idea):

    http://www.farmersmarketblablabla.org

    can you see anything missing?

    i really appreciate you being here!

    ~ susan

  8. I can't tell without seeing the exact html string you are using. Are you using the code tab, or the visual editor when you create the link?

  9. thenaturalkitchen
    Member

    visual editor

    here's the website link for the two sites i'd like to link to my site:

    http://www.troyfoodcoop.com/

    http://www.troymarket.org/

    and my site, again, is - http://www.thenaturalkitchen.wordpress.org

    does this help?

    thanks!

    thanks!

  10. First off, what browser/version and operating system are you using?

    Both of the links are active and working. I can give you the exact code to paste into code view in your editor, but that isn't going to get us to a point where you can do it, so let's try it again. Perhaps write this one as a page named "test" so that if it doesn't work, I can use "view code" in my browser on your blog to see what is happening. Make sure and "publish" it so I can take a look.

    1) In the post, highlight (select) the text that you want to use as the link.
    2) Click on the icon that looks like linked chain links
    3) In the "Link URL" field paste the appropriate link that you copied from your browser address bar
    4) Click the "insert" button.

    In the edit window the text should be highlighted in blue and underlined indicating it is a link. Do the same for the other link.

  11. First off, what browser/version and operating system are you using?

    Both of the links are active and working. I can give you the exact code to paste into code view in your editor, but that isn't going to get us to a point where you can do it, so let's try it again. Perhaps write this one as a page named "test" so that if it doesn't work, I can use "view code" in my browser on your blog to see what is happening. Make sure and "publish" it so I can take a look.

    1) In the post, highlight (select) the text that you want to use as the link.
    2) Click on the icon that looks like linked chain links
    3) In the "Link URL" field paste the appropriate link that you copied from your browser address bar
    4) Click the "insert" button.

    In the edit window the text should be highlighted in blue and underlined indicating it is a link. Do the same for the other link.

  12. thenaturalkitchen
    Member

    hi there

    i'm on Windows XP Home Edition. i'm making my blog on mozilla firefox (maybe the problem yesterday was that i accessed the wordpress site through my e-mail which was in internet explorer)

    as you suggested, i made a new test page, under the Home Page category, with the 2 links mentioned above.

    i'll try it again on my real page and see if it works, making sure i'm in mozilla, not internet explorer. hopefully i can get it working, as i've got some more ideas for links today!

    thanks again :)

  13. If it is IE6, it can be problematic. Try again with Firefox. Also make sure it's the latest version of FF which is 2.0.0.11 I believe.

  14. thenaturalkitchen
    Member

    okay - what in the world is wrong with my blog??

    the test page shows active links, but in only a very slightly different shade than the rest of the text, so you'd have to be looking very carefully for the link, otherwise you might not notice it.

    and why this scenario - on my computer, in mozilla, i show the links on the original home page, one in bright purple, and one in blue underlined. but on my husband's computer, on internet explorer, he shows no links on the home page, but the test page shows the links in the same "barely detectable" shade.

    how can i remedy this once and for all and keep building/creating new "noticeable" links? am i going to have to go in and make each link a different text color manually? that would be lame.

    is it something about the theme template i'm using? i hope not, because its the only one i really like for my site's theme.

    i do appreciate the efforts to help, and i'm seriously frustrated.

    thanks ~ susan

  15. thenaturalkitchen
    Member

    how do i find out what version of firefox i'm on? - thx!

  16. The slightly different color is the way that theme was designed. To change he color of the linked text, you would either have to have the paid CSS upgrade and some CSS editing experience, or you would have to change the color of the links manually on a link by link, and post by post basis as described here:

    http://faq.wordpress.com/2006/06/12/can-i-change-my-font-font-size/

  17. To find out your version, go to the help menu and to "about" and then it will be listed in the screen that pops up.

    On the difference between FF and IE, that is common. Each browser will interpret and render pages slightly differently. It's a shame they don't all display in a standard and consistent way. It would certainly make for an easier time for designers. Now they have to review their designs in every browser and keep making adjustments here and there till they reach a compromise that works with all browsers.

  18. thenaturalkitchen
    Member

    thank you for being here!

    okay, i'm on the latest version, just as you wrote it above - 2.0.0.11

    did you get a chance to look at the test page on my site, and then the original home page which is directly underneath it in the same thread? what do the links look like to you?

    again its- http://www.thenaturalkitchen.wordpress.com and the test page is under the Home Page category.

    thx again

  19. /nod to tsp

    Just popping in to say those links look like all the other text in IE7.

    Link colors can be changed with the css upgrade.

  20. thenaturalkitchen
    Member

    hey ellaella

    were you looking at my actual blog page?

    thx

  21. From the link above I clicked on Home on the sidebar. There were active links on that page because the snap preview worked. But they look the same. I had quention on a test for a while and seem to recall this issue.

  22. thenaturalkitchen
    Member

    bummer. thanks for checking it ellaella.

    well, i tried a few other themes on for size, and i really like Quentin's look for my site better than anything else. so i guess i'll work with its bugs and figure a way around them - maybe i'll just post the actual web addresses for anything i want to have a link for, and my readers can click on the web addresses instead of a "fancy" text link.

    of course, if anyone has more advice on how to make a workable text link, in Quentin theme, using mozilla firefox, and using the rich text editor (i'm not so html savvy) - i'd be very happy to read it.

    thesacredpath - if you have any other thoughts i welcome them.

    and thanks thanks thanks!

  23. You can change the link colors with the css upgrade. Here is the section to change:

    a {
    	color: #5B211A;
    	text-decoration: none;
    }

    If, for instance, you wanted blue links, change the color

    a {
    	color:blue;
    	text-decoration: none;
    }
  24. thenaturalkitchen
    Member

    thanks for that ellaella,

    but wouldn't we also be able to change text color using the advanced toolbar?

    to be clear, i open the advanced toolbar by clicking the icon on the far right in the main toolbar menu when using the Rich Text Editor. this opens up a few more options, one of which is text color choices.

    i think i may have figured out a way to make my links more noticeable - i'll post here when i see if my plan is working, in hopes that it may help someone else.

    ~ susan

  25. I've changed the color of a word or two with the toolbar, but never a linked word, although I don't see why it wouldn't work. If you've got the patience to do it every time, go for it. :)

  26. thenaturalkitchen
    Member

    well, i figured a way to make the links work, and to make them noticeable to the reader.

    i just used the actual web address as the link, to make it more obvious to the reader that there is a link there.

    anyone who who is interested - you can see what i mean on the welcome page when you visit my site (referenced a couple of times above).

    thanks for all the help and effort on my humble behalf... ~ susan

  27. As another idea, you can also make the text bold or italic to make it more noticeable. I've done that in the past on some themes.

  28. The links are always there, you just can't see them. Quentin is designed to make them subtle. I think it's actually a way to force you to pay for the CSS upgrade to make them more visible without the hassle of manually recoloring or underlining each one.

    You can see that they're there by running your mouse over them. The cursor will change shape to show it's a link you can follow. The only way a reader would know that though, is if you manually edited each link and changed the color/style, bought the CSS upgrade, or put a big sign that says CLICK HERE!

    No such thing as a free lunch here.

  29. Got to disagree; Quentin was a theme long before we had the option of the CSS upgrade. I've yet to see WP.com do anything venal to pimp out upgrades. If anything, they're more likely to say "try self-hosting".

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags