Need help? Check out our Support site, then


WHY IS IT SO HARD TO LOG INTO THIS BLASTED SITE?

  1. I've tried to do a screen shot, following the instructions on the site, but nothing happens.

    The error message is in a rectangle, with a red column on the left-hand edge. The message reads as follows -- "ERROR: Invalid email or username. Lost your password? [This is a link to the password reset] The login box is just below that rectangle with boxes for the login information. Below the login box are links for "Register," "Lost your password?" and "Return to Property Rights Ombudsman" The rest of the screen is blank.

    Could the problem be Internet Explorer? I am able to log in using Google Chrome, although I prefer to use Internet Explorer.

  2. Hi erlawrence,

    I'm sorry that this has been an ongoing frustration for you, and thanks for the update.

    Since you can log in using Chrome, it sounds like something's up with IE. Can you tell me what version of IE you're using?

    Also, please let me know if you have third-party cookies enabled in IE: http://en.support.wordpress.com/third-party-cookies/

    When you log in, are you using your username or email address in the login window?

    Are you running IE in Compatibility mode? http://www.howtogeek.com/128289/how-to-disable-compatibility-mode-in-internet-explorer/

    You might also want to make sure *.wp.com and *.wordpress.com are trusted sites. http://answers.microsoft.com/en-us/ie/forum/ie9-windows_7/how-do-i-add-a-site-to-my-trusted-sites-list/98cc77c8-b364-e011-8dfc-68b599b31bf5

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags