Need help? Check out our Support site, then


Why won't my images upload?

  1. Every time I try to upload an image, it begins to load, but then partway through, the loading bar fills, changes to "Crunching" and never actually uploads. The percentage varies from about 25% uploaded to over 80% uploaded, but my images won't finish.

    I've noticed this issue only in the last few weeks - before, it always worked with no issues.

    I've tried clearing my cache and cookies, as suggested in the troubleshooting, but it hasn't worked. What is the problem?
    Blog url: http://talesfromhebei.wordpress.com/

  2. (1) Are you creating posts on the main page of WordPress.com at this link? http://wordpress.com/#!/post/
    If so, don't do that. Create posts on your own blog's dashboard at this link instead. http://talesfromhebei.wordpress.com/wp-admin/post-new.php

    (2) Are you using the secure https:// login?
    http://en.support.wordpress.com/https/

    (3) Exactly which browser and version of it are you using. If you aren’t sure click here to find out > http://whatsmyuseragent.com/

    Note 1: If you are using an IE9 browser in compatibility mode that makes it render as IE7 and IE7 is not supported. To disable see > http://www.sevenforums.com/tutorials/1196-internet-explorer-compatibility-view-turn-off.html

    Note 2: If your browser version is outdated you can upgrade it here http://browsehappy.com

    (4) For details about the options for uploading images see:
    http://wpbtips.wordpress.com/2009/04/26/images-the-three-link-options/

    (5) For troubleshooting images tips see > http://en.support.wordpress.com/images/troubleshooting-images/

    Prior to uploading any image into your blog, regardless if it’s a header image, a featured image, an image in a post or page, in a Post format (Gallery or Image), an image for sidebar display in an image widget or a text widget, you can optimize and re-size it in either a desktop image editing software or online image editing software to fit the space you intend to use it in. By undertaking proper image preparation first you will get the best image quality, won't be wasting your media storage space, and won't be wasting your time troubleshooting.

  3. 1. I am not using the main dashboard "quick post" thing. I am always using the "Add New Post" option and going to it's own page.
    2. I will try using the secure login and see if that helps. I am reading that it may slow down WordPress, which is already a bit of an issue since I am in mainland China and have to use a VPN to access it already (which may be part of or all the issue here - internet speed/connectivity/dropping connections).
    3. I am using Firefox, and when I've checked, it says it is the most up to date version.

    As far as I can tell, the files are not too large (is 250mb or so 'too large'?), and I have plenty of storage space left.

    Like I said, I am starting to suspect that the culprit is my internet connection/VPN combination, but there is little I can do about that, I think. Sigh.

    Thanks for your reply!

  4. Hi there,
    I flagged this thread for a Staff response. Maybe they can come up with a bright idea that you and I don't will help you.

  5. Thanks for trying to help - you say you flagged it for a staff response, right? Do you know of a way to contact them directly for help (whenever I try the 'Support' area, it just takes me here, to post in the forums)?

    Anyone at WordPress reading this?! Waiting for some help here...

Topic Closed

This topic has been closed to new replies.

About this Topic