Need help? Check out our Support site, then


Widget showing up everywhere but home/blog page

  1. My home page displays my posts. I want a widget to display on the home page and certain other pages, but not all pages. When I try to set specific visibility rules (rather than leaving visibility unset, so that the widget shows up on all pages), I can't find one or a combination that will cause the widget to display on the home page.

    I have a site (in testing) with a made-up example of this: potbrained.wordpress.com, themed with Twenty Thirteen. The home page shows in the nav menu as "Blog," which is just a link to the site. (I have tried it without this menu item, no difference.) I have five widgets on this site. Four of them have visibility unset, so they display everywhere, including on the home page. With the fifth, Recent Posts, I have tried the following visibility settings, with no success. Most of these I would not have tried, logically speaking, but for the sake of testing.

    1. Page is Posts page,
    2. Page is [Static page] Blog,
    3. Category is All category pages,
    4. Page is [Post type] Posts, and
    5. Page is [Post type] Page.

    I've tried these alone and in combination. The only way I have successfully displayed the widget on the home page is to leave visibility unspecified. I've explored the forums and read posts here and on other sites about widget problems caused by malformed or unclosed tags. I've looked for this problem in each post; if it exists, I'm still missing it. I've tried checking each of the category pages and don't have problems with widgets there. Wouldn't the widget fail to show up on a category page if there were tagging problems in a post in that category?

    I should mention that this problem cropped up after the blog was in gear. I only noticed it about a week ago; Ireally wasn't paying attention to widgets and I'm used to them showing up at the bottom of the page when my browser window is too narrow. I've checked the more recent posts particularly carefully (which doesn't mean I'm not still missing something).

    I also am wondering whether the visibility settings have changed slightly; the menu itself looks different to me, I didn't see (or didn't notice) the Post type settings before, and I'm have this inkling feeling that I was using a different setting for the home page that I'm not finding anymore. I didn't write down the settings I was using so I'm just not sure. I did experiment with other themes in the beginning but only by applying them, taking a quick screen shot, and going back to Twenty Thirteen (no changing of settings), and I haven't made any changes since the problem started.

    I am new to wordpress.com. Is the problem staring me right in the face? Any suggestions?

    The blog I need help with is potbrained.wordpress.com.

  2. danielisreading
    Member

    Hmm seems that there is no option for the 'home page' of the blog, if it just shows your posts, I'm a little surprised at that.

    But, you can work around this, by using the 'Hide' function, obviously it might not be exactly what you want, since it might mean you have to put more 'rules' down, but it will still show on the 'home page'.

  3. I'm not finding a reference for a Hide function with respect to the visibility of widgets. I'm familiar with hiding pages from navigation but that's not what I need here. Can you point me to more information?

  4. danielisreading
    Member

    Sure, when you click on visibility, you should see a dropdown menu saying 'show', if you click on that, you should find 'hide'. Just click that, and then use the same options for 'show' to select which pages/posts/categories you don't want the widget to show up in.

    http://en.support.wordpress.com/widgets/#widget-visibility
    http://en.blog.wordpress.com/2013/05/15/conditional-widget-visibility/

  5. Geez, it really was right in front of my face. If I had bothered to actually look at the interface instead of my guidebook, I probably would have noticed. Thanks!

  6. Hi there!

    It seems you figured out the answer with @danielisreading's help. Let me know if you're still having trouble and I'll be happy to look into this further.

    Happy blogging!

Topic Closed

This topic has been closed to new replies.

About this Topic